Streaming live at 10am (PST)

High Security Option In Internet Explorer Doesn't Show Animation?


#1

I have an animation interaction on the ‘hub’ page of my website under the ‘support’ folder (see link to my read-only site below).

On page load the ‘how are we doing’ section is supposed to animate by flying out from the left:

image

It works on every browser and setting. However on testing in Internet Explorer, if you put the security up to High, this feedback doesn’t show. I’m assuming it must be using something fancy that Internet Explorer is blocking?

Is there any way to fix this?


Here is my site Read-Only: https://preview.webflow.com/preview/virtual-cabinet-449919?preview=8748b2f77969d2f8c6ac69032e07cddc


#2

Hello!

Thanks for reaching out, and excellent question.

While I haven’t used Internet Explorer in quite some time for regular browsing, I know that the High Security mode can change the display of websites that use Javascript. I also believe that Internet Explorer is no longer supported or developed, and some features such as the CSS Flexbox styles may not appear correctly in all cases.

You can see Microsoft’s information for High Security mode here:

Web pages may not be displayed in Internet Explorer as you expect, and applications that require the browser may not work correctly because scripts, ActiveX Controls, the Microsoft virtual machine (Microsoft VM) for HTML content, and file downloads have been disabled. If you trust an Internet site and need it to be functional, you can add that site to the Trusted sites zone in Internet Explorer.

Unfortunately, I don’t believe this is a Webflow limitation, but rather a legacy browser limitation for a specific setting. You may be able to remove the interaction or try to change the trigger and test it out in IE with High Security. Otherwise, you may not want to use this specific interaction here if you intend to support legacy browsers.


#3

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.