Streaming live at 10am (PST)

Home page nav bar links stopped working


#1

It seems that something has broken the links on one of our nav bars. Previously, all of the bars and links worked. Now if you click on News / Features / Reviews / Backlog or the logo in the top left, none of them work. The bar links now just go to /#. The home page

The nav bar above it (with Home, Categories, etc) is unaffected. We’ve not altered these links in months. Has a webflow update done something?

There are no console errors.

Any help appreciated!


Here is my site Read-Only: LINK

Published link:


#2

It looks like this is also affecting the sliders. It is worth noting that this is fine when not logged into the CMS, so it looks like a CMS-specific issue.


#3

Just tested them on preview and .io and they work fine, leading to the appropriate categories pages.


#4

Hi @andyp2,

Thanks for posting about this. I’m seeing the same behavior @vincent is — it looks like the links are working as expected for me on the webflow.io subdomain and Read-Only link.

Has the issue been resolved? If you are seeing other behavior on your end, can you send me a screen recording of what you see (CloudApp or Quicktime work well).


#5

Apologies, the initial description isn’t clear on the issue.

This issue occurs when logged into the editor, clicking on any nav link to simply surf to that section while editing content does not work, did previously.

e.g.

  • Log into editor
  • Homepage
  • Highlight ‘reviews’ in the secondary navigation - not to edit the text, just to click on the link to go to that section
  • Link doesn’t go to the page in question, defaults to - https://www.jumpdashroll.com/#

jdr%201


#7

Hi @andyp2

Thanks so much for the response and for clarifying the issue here.

I did some more testing on this end and I’m able to see the issue when working with your project. It’s odd though, if I set up a brand new site with a similar navigation, it works as expected.

I’ve reported the issue to the team and we will check into it further to see what the issue is. For the time being you can use the Editor Interface to navigate to the collection pages — not ideal but it should unblock you and your client while we look into this glitch.

Thanks again for your help here!


#8

Hi Brando - is there any update on this? Cheers!


#9

No updates at this time @andyp2. Can you please try the following steps to see if this helps?

  • Go to your custom code in your project settings
  • Temporarily remove that custom code in the head and footer fields
  • Publish and check the Editor

This will confirm whether or not the issue is caused by the custom scripts — unlikely, but It’s always good to rule this out.

​Thanks in advance!


#10

Hi - no, I just tried that and the links still direct to /#

Let me know if you have other suggestions… it’s a pain to navigate inorganically.


#11

Thanks for testing that @andyp2 — I’ve notified the team and we’ll continue to investigate


#12

Any update on this please?


#13

Hey @andyp2! I’ve just checked and the fix is still wip… I’ve added a reminder for the team to get back to you as soon as we have a solution. Stay tuned!

Cheers,
Bart


#14

Hi. Can I have an update please?


#15

Hi @andyp2

Thanks for requesting an update – our team is still looking into this one.

I’ll definitely respond back here as soon as I have new information for you. Thanks in advance for your patience!


#16

Hi @andyp2

Can you please try to delete these links, then re-create them? Once that is done you can publish and test to see if the issue is resolved in the Editor.

​Thanks in advance!


#17

Hi Brando - I’ve taken over from Andy in managing the site.

Thanks for the tip - removing and re-adding the links seems to have fixed it! Any idea what the cause might have been? As was said, we haven’t touched these links at all since they were added.

There is one issue remaining which is the logo in the top left which is supposed to link back to the home page. This is a link block with a logo in it, and it seems that the logo is covering the clickable portion of the link itself. I can see this in the designer - it only changes to the link settings icon around the point that is marked in yellow below:

image

Is there a way of bringing the link forward so that clicking anywhere on the logo will direct it to the home page?

Thanks!


#18

Hi @RobJDR

Glad to hear that fixed it!

If you need to update that link regularly, one method you can use is to add a small amount of padding on the right side of the link block. With the current px based width of the link block this will squish your image, but if you set the width of the link block to auto first, you can add this space without any trouble:

CloudApp


#19

Thanks - we don’t need to update the link regularly - it will always just need to go to the home page. Can I make the entire logo the clickable area to do so?


#20

On the live site the entire logo is clickable, only in the Editor will you see the brand image not link to the home page. This is because anytime you hover over an image in the editor, the option to change / edit that image takes priority over it’s parent link element.


#21

Oh of course! Sorry, was having a moment. Thanks for the help!