Streaming live at 10am (PST)

Horizontal scrolling problem in browser (Hidden overflow)

Hi, In this test site everything is fine (for the moment) except that in one of the elements (Foggy-inf), I applied an animation (Scale) which shows a horizontal scroll, but all the elements have Overflow Hidden applied .

If I remove the animation (scale) it works fine.

Why?
Thank you !!!


Here is my public share link: Webflow - Uniko

Loom video: Loom | Free Screen & Video Recording Software

Welcome to the community @Minoumax!

Your position: absolute setting is more than likely the issue here, as it takes the element out of the document flow and negates the hidden overflow property that you’re setting.

Try setting the foggy image container to position: absolute with hidden overflow but keep the image inside as static. You may need to play around with the sizing of the container after you change those settings but it should hide any horizontal overflow on the page :+1:

Hi! You are my hero!! ja ja :smiley:

I had not thought of it! Indeed there was the solution, thank you very much!

The community is 50% of Webflow :+1:t3:

1 Like

Glad I could help out! Looking forward to seeing how you use that setup on a future project, the effect is rad :metal:

Hi Mikeyevin,

I also have a similar problem, Can’t figure out why my homepage is overflowing and enabling horizontal scroll, are you able to take a look?

Just gave my .02 over in that thread, but I’ve included my response below for anyone who stumbles upon this thread: