Streaming live at 10am (PST)

How Do I Copy An Element From a Dynamic Page


#1

I’m trying to copy an element with sub-elements from a dynamic page, and paste it to a blank dynamic page because I created a new CMS Collection.

I also have a free premium template when I created my account the other day, so I’m not sure if this is a template issue, or a Webflow issue.

Is this a template issue, or a Webflow issue?


#2

Remember the components added on a Collection Template Page are the same as a non-collection page. The only difference is the “Binding” of data to fill the components with content, that’s really it. So when you add a div on one template page for 1 Author, and fill it with an image, the purple binding will ask from where? You’ll click image from the collection, then it shows on all the Author pages (In the dropdown toolbar).

You only need to add and create the component once. It repeats on each page from the dropdown. The image changes are made in the collection of that author.

Please clarify if I’m incorrect in what you’re asking.


#3

Hey @garymichael1313,

Thanks for responding.

The issue I’m experiencing is quite… basic (I’m at a loss for words).

Essentially, when I copy, for example, a Section element that has various sub-elements (like Div Blocks, Text Blocks, etc.) from any pre-manufactured dynamic page on this premium template I got access to and try to past the Section element onto a new dynamic page (new CMS collection) it won’t paste. The right-click menu behaves as if I didn’t copy anything at all (paste options are greyed out).

I’ve even tried copying basic non-CMS binded elements such as a regular Text Block, but when I try to paste it onto a new dynamic page (new CMS collection page) the right-click menu still behaves as if I didn’t copy anything.

Would a video help to show what I’m describing?


#4

Hi @anonmusic

I get this sometimes in the designer. I usually use the shortcuts CMD+C and CMD+V to copy and paste, respectively.

You need to select the element first, then on the blue element tab, right click to copy instead of using the shortcut. My Mac makes a “doink” sound if it hasn’t copied using the shortcut.

It often annoys me, but a quick refresh of the designer sorts it out for a while.

Not sure if that’s your issue or not, hope it helps!

21

You also can’t copy elements from a dynamic list onto a different dynamic page without first disconnecting the fields first. It’s a good idea to have a normal page with all the styles set up so you can copy and paste from there, then connect the dynamic file.

If that’s the case though, you normally see an error in the top right hand corner telling you this.
30


#5

Here’s what I’m experiencing:


#6

OOHH!! I figured it out!

I had to expand all the elements in the Navigator area (right side of the Designer) and locate the dynamic elements (unchecked the option to pull data from the CMS Collection).

Once I did this, it finally allowed me to copy/paste an entire section from the default template page!


#7

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.