Streaming live at 10am (PST)

How to activate Lato - Semi Bold?

Hey y’all,

I’m pretty sure I’m using the latest version of Webflow and I’ve seen other threads in which the dev team mentioned the bug has been fixed so I’m pretty sure I’m doing something wrong.

All I want to do is be able to select 600 - Semi Bold in this screenshot.

Hi there.

There is no bug.

Lato does not offer 600 Semi-bold, even through Google fonts. I do not know of a way to push this through if it does not have the option for it. You could use custom CSS styling, but you would still be limited to the Google Font Api, unless you were able to find it through a different font catalog with 600 - semi-bold available.

Hey Brandon,

Thanks for clarifying that. It’s seems weird for it to then show that option in the list, right? Not sure why Lato doesn’t support semi-bold or other variants here since we were able to use it fine in Sketch. We made sure the Google font was downloaded directly from the repository.

@darth512, it doesnt show it in the list. Font weights that are in “white” are available. Weights that are "darkened’ are not available.

The Lato font in Google DOES NOT have semi-bold available. Not sure what you were looking at.

CloudApp

CloudApp

You can see in the gif between the two.

You’re right. Thanks for clarifying. I wonder if someone in my team downloaded an earlier version of Lato which supported Semi Bold because we definitely see it in Sketch which is the weirdest part.

Google is just not serving the weight you desire. I use this font in Adobe Creative Suite, Sketch, and Affinity.

So you could upload your own custom web fonts to Webflow. Lato would require generating your own webfont kit if you wanted the new version.

1 Like