Streaming live at 10am (PST)

How to allow google search

Hi there,

I’ve set up SEO, but when search my site, it still appeared like this:
19%20PM
(no information is available for this site), and I’ve read Learn why, and changed the robot.txt as:
User-agent: *
Disallow:

But still not working.

Hi Denian,

Can you give a bit more information? A link to the published site? read-only link?

1 Like

You do not need to use the google disallow button here.
Just go into the settings and make sure the Webflow SEO is disabled and page indexing is on.

That should work.

Also you can go to Google Search console and setup your site. This will give you a lot of info on your site and have Google crawl you’re site immediately. If you need any help just let me know. jw@orangecattle

https://preview.webflow.com/preview/eazydoc?utm_medium=preview_link&utm_source=designer&utm_content=eazydoc&preview=d27e8c3c5ca579caa8403272818e4439&mode=preview

Hi avivtech, here’s the link. I’ve set up the SEO in the Designer> Page setting

It might be that your edit to the robots.txt file is what causing this.
If you read the 1st paragraph here you can see that the line User-agent: * makes this file applicable to all robots, and the line Disallow: / tell them they are disallowed from all the website. Since your edit is almost identical, I guess that is the problem.

Try deleting your robots.txt edit and leaving it empty.

1 Like


Thank you so much for your help! So my Indexing is like this now, but still when google ‘eazydoc’, it appeared as ’ No information is available for this page.’ Is it because google takes time to implement the changes?

Thanks!

Probably.
I’d recommend turning the disable webflow subdomain indexing On.

Recommended reading ->

https://support.google.com/webmasters/answer/7451184?ref_topic=9268559