Streaming live at 10am (PST)

How to apply one effect for several dropdown button

It’s ok for the effect on “deontologie” button.

But I trying to apply the effect on the two others dropdown buttons. For that I set the two others with the same class “dropdown”and “dropdown list”, I selected class button instead element buton in the effect panel and inside effect, I set a “close delay” and Overflow hide on each dropdown button. But doesn’t work with the two others “qui suis je” and “specialites”.

https://preview.webflow.com/preview/jessica-project-7813d5?utm_medium=preview_link&utm_source=designer&utm_content=jessica-project-7813d5&preview=e2a9cba94283de30078c5f058771b48f&mode=preview


Here is my public share link: https://preview.webflow.com/preview/jessica-project-7813d5?utm_medium=preview_link&utm_source=designer&utm_content=jessica-project-7813d5&preview=e2a9cba94283de30078c5f058771b48f&mode=preview
(how to access public share link)

Hey @karle,

It looks like a simple fix by changing the affected class option. In your interaction panel, change the affected class to this only parents with this class
image

Should solve your issue!

Hi imtiazraqib,
Thanks for your help.
I tryed your solution but When I do that the effect doesn’t work at all even on “deontologie” button.

Is your read-only link updated? I can take a look into it for you!

Yes you can, it’s my read only link.
I think you can juste modify not record.

Hey @karle,

I just worked on the same solution I mentioned and it works. To be more precise, you have to do this to your dropdown open interaction.

Solution:

Result:
ezgif.com-gif-maker

I can’t do it. Apparently the effect is not working on your video. It is too fast. It’s as if there isn’t effect at all.
I set again with “all element with this class”, “Deontologie” button works well now but not the two others. You can try in order to compare.
If you figure out the solution, could you please make me a video to show me ?