Streaming live at 10am (PST)

How to change order of CMS collections/items

Hello,

how do I change order of the CMS content in Webflow?


Where does it get the order from now, and how can I change what i want to appear first, second etc.

Havent been able to figure that out…
thanks

Hey @rdngon

Here you go!

1 Like

No way (yet) to reorder the elements by the ui (drag and drop). For now sort by date, name and so on -or- by custom number feild manually (follow @donaldsv link).

2 Likes

The best way to control the sorting is to create a field in CMS, say, “Sorting” in the collection.

Set the Sort Order of the collection by “Sorting” field that you created in the CMS.

Add numbers 1,2,3,4, to each item via CMS, the way you’d like it to be sorted.

You can now sort the collection anytime, by changing these numbers through CMS.

You can also use 1.5 as a number in CMS, if you are looking to add something between 1 and 2 later.
Gives you good control.

4 Likes

This sounds good but doesnt work.

These two have 1 and 2 in order

Yet are at bottom

Also dont know why it says not published

@Arialwal

@donaldsv and @Siton_Systems thx for link but doesnt work for me. dont see anywhere it says sort order.

Anyone knows? Thanks…

Can you please share your read-only link?

Been using it for quite some time. Create a Sort field in the CMS.

Follow this:

  1. Create a field in the CMS named “Sort” or whatever you’d like.
  2. Add the values 1,2,3,4.

After that, follow this guide.
i.e

  1. Go back to editor and click on the “Collection List”
  2. Click ‘Settings’.
  3. Add a “Sort” and order by the “Sort” field you Just created.

This works for me.

If you need further help, share the read only link:

2 Likes

THANK YOU :smiley: Worked perfect!!

@Arialwal Follow up question if you dont mind :smiley:

Im trying to make it clickable, but it says no fields to connect to.

I also see that in the CMS the status is set to “staged to publish”. Yet i dont see a “publish” button.

Is this why link isnt working? cause the cms pages isnt published? in that case > do u know where i can publish it/where this button is?

Don’t use the Get URL. Use the “Collection Page” option in “Link Settings” under settings.

Use Get URL only if you have a specific “URL” field in the CMS, for custom URL’s.

Staged for publish: Simply publish the website from the Editor and everything will be published.