Streaming live at 10am (PST)

How to change the number of sliders


#1

Hello,
I have a portfolio project section. Each project has a different number of images. Is there a way to have each image slider have its own set number of images. Right now it looks like I am constrained by the number set by the CMS builder fields. Example: In the project tab:


Each project is set to 5 images so if a project has 3 images, 2 automatically are set to a blank grey slide which I want to avoid.


Here is the link to my site:


#2

It looks like your Conditional Visibility strategy works. So there’s only 1 gray spot showing up per slider.

It seems that with CMS sliders you’re always left with a blank slide. it’s actually a spot that shows the background of the Slider. if you define a background for the slider, it will show up the same at the end of each slider. Not ideal but doesn’t look blank. You can place a CTA there.


#3

@vincent I’m trying the workaround you suggested for the blank slide, but I might be missing something basic here… When added div block is under the slides (lower z-index) the CTA can’t be clicked. If I give it a higher z-index it shows the CTA over all the slides. What am I doing wrong here?

And while I’m here - Webflow please add CMS sliders as a component. It’s been on the wishlist for quite a while and is really a necessary feature.


#4

@vincent I like your answer.
@yeshai did you try added div block with identical z index. It sounds like you want added div block inside slider but it is not inside slider? correct?


#5

@Steven_Harris Thanks. I tried it but each slide has a different z-index. The mask is set to z-index=1. When I set the div block to z-index=1 (it is inside the slider) it shows as expected when the empty slide is hit, but isn’t clickable.
17


#6

@yeshai I have not been able to identify problem. Sorry I can not help at this time. I will try to replicate on one of my sites at some point but no time this morning.
@vincent Can you help Yeshai?


#7

@Steven_Harris appreciate your efforts. Thanks.


#8

Ideas how to fix this, anyone? Getting close to finalising this website.

Here is my shared link: https://preview.webflow.com/preview/neta-sade?preview=bcbb7997c86ff20ad6c6a5836bc6d2c5 - the problem appears on the last slide of any project slider.