Streaming live at 10am (PST)

How to Disable Safari Overscroll?


#1

Hi friends,

Publish link: http://good2andh.webflow.io/
Screenshot of problem: https://lh3.googleusercontent.com/-wlWm2yRU2zNl8rp4ZJ1ZrPIpiZ-9Psl6FO874_tVDkUh4EERc227LReLXYj5-z7Tc1YduxrXUIRpcYroRUzHTjaDg=s852

In iOS Safari, my -1 z-index section/div appears in the overscroll.
I have tried a fair amount of possible fixes I found on google.
But I'm not the most advanced developer so nothing is working for me yet.

I realise the solution may be to disable overscroll for Safari browser but I'm not sure how.

Once again, any help is appreciated.
Do higher plan accounts receive greater support?

Thanks


#2

Bump.
Hopefully someone who knows a solution sees this.


#3

I'm not sure about how to 'disable Safarai overscroll', but I ran into a similar problem the other day with a fixed element (a navbar, in my case). My solution was to work with what I had; i.e. Webflow. I setup an interaction to hide the fixed navbar when a particular element was on screen, and reveal it when it wasn't.

In your case, if you add an interaction to the 'footer' section that sets the 'hero' section (you can set them up to affect different elements when triggered) to display none when it scrolls into view and just reverse it (i.e. display: block) when it scrolls out of view. That should do it!

Let me know if I haven't explained it well enough.

Oh, and a little tip to get it looking real shmick (not sure if that's just an Australian term), if you set the background colour of the page to match the footer colour (you'll need to set the different background colours for the other sections though) you only see that dark blue colour when you scroll passed the edge of the footer. Just a nice touch.

Cheers

Mark


#4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.