Streaming live at 10am (PST)

How to disable Webflow redirect

Hi everybody, I initially had a page /terms-of-service and then I created a copy of it as /terms-of-service-original.

The issue I am having is that after I deleted both of these pages, when I try to create just /terms-of-service , this page now redirects to the non-existing /terms-of-service-original. It looks like Webflow at some point created this sticky redirect.

I looked in the Hosting Settings page to try to delete the redirect but it is not there. I tried to delete the /terms-of-service again, followed by any combination of unpublish/republish/ recreate the page, etc… Nothing seems to work if I use the same page name (or slug) because somehow Webflow has a redirect to a non existing page saved somewhere out of my reach. Changes in Designer do not affect the hidden redirect…

Any ideas on how to delete the redirect?

Thank you!

Redirects can be cached by your browser. Try clearing your browser cache or test with alternative .

Thank you !

That fixed it. I did not know redirects are cached by browsers.