Streaming live at 10am (PST)

How to force a background video to autoplay with Javascript


#1

After your update, my background video is not working…
Please fix it or let me know how to fix it.

Thanks
my address is

www.dongokmoon.com


Here is my site Read-Only: LINK
(how to share your site Read-Only link)


#2

It autoplays well for me.


#3

Hi @Moon_Dongok,

Your background video seems to be loading as expected here is a GIF with what I’m seeing on my end.

If you are still experiencing this issue, can you please try the following:

(1) Clear your browser’s cache and republish your site and check if that solves the problem?

(2) Try to reproduce the error by accessing your site usingIncognito mode with browser extensions turned off.

Hope this helps :slight_smile:


#4

I fixed to do some custom code.
here is the custom code what i fixed.

script> (document).ready(function() { (‘video’).each((i,v) => {
(v).prop('muted', true); (v).attr(‘data-keepplaying’, ‘’);
v.play(); });
$(’#fullpage’).fullpage();
}); </script

basically, the chrome has some security issue for the video autoplay.
so if there are unknown video then they are block the autoplay.
in this case we can muted the video to use autoplay function.

I hope this can help for other people. :slight_smile:

Moon


#5

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.