Streaming live at 10am (PST)

How to make text field disappear when visiter starts to type in the Form block


#1

Im trying to have the text disappear in the form block when you type info.


https://preview.webflow.com/preview/realestate-bdc930?utm_source=realestate-bdc930&preview=42e876997b1bc1a43131b82e90be6f8a


#2

Really easy fix. You were using text behind the form input fields instead of writing the placeholder text in the input settings.

  1. Double click your symbol to unlock it.
  2. Select an input in your form
  3. Then click the settings icon in the blue label for your input like in the photo below
  4. Now you can write whatever text you want to show up as the ‘placeholder’

Now you can actually style the placeholder text as you wish as well.
To do that just look at the last photo I posted and remember to have your input field selected as you do this.

In the design panel to the right, at the top you will see where it says “States”. Click that and you will see “Placeholder” as an option. If you select that it will target the placeholder text so you can edit the text as you would any other text on the page.

Hope this was helpful! :relieved:


#3

Thank you, that worked!