Streaming live at 10am (PST)

How To on using your own form processor with webflow form

I keep getting this error

The following potential problems were found in your configuration:
Warning: Your TARGET_EMAIL pattern “^” is missing a $ at the end.

I’ve added “$” to the end and it still doesn’t work.

$TARGET_EMAIL = array($EMAIL_NAME . "@ethanfoxdesign\.com$");

not sure if it matters but the period looks out of place. TARGET_EMAIL = array(EMAIL_NAME."@myDomainName\.com");

After starting to get an increasing amount of spam, I decided to add reCAPTCHA to my form. I ran across this thread, which helped, but apparently not enough. I’ve added the pertinent entries, and the reCAPTCHA box shows up in the Designer, but not when I upload the files to the server.

Here’s the form HTML -

And here’s the formmail.php entry - (with a fake Secret Key :wink:)

/* Help: http://www.tectite.com/fmdoc/require_captcha.php /
$REQUIRE_CAPTCHA = “”; /
set to a message string if your forms */
// must provide a CAPTCHA string

/* Help: http://www.tectite.com/fmdoc/recaptcha_private_key.php */
$RECAPTCHA_PRIVATE_KEY = “6Lc3OkMaYYsteDI1HiE_A9FnI-UXNSVtyv8bNw75”;

So it looks like it’s trying to work. Just wish I could get it across the finish line.

@sebreme provide your read only link to the designer and I will take a look at the page.

I have the same problem and here is my Read-Only Link:

https://preview.webflow.com/preview/spiroklima?utm_medium=preview_link&utm_source=designer&utm_content=spiroklima&preview=eb4292631f05a5b347cfedb3a6a8a6d7&mode=preview

I have changed the private key as it needs to be confidential, but can you see any matters with the form?

The final site is https://www.spiroklima.at

Thanks for your help!

remove the redirect url from the form setting and it should work!

2021-02-22_9-32-10

we generally can never help anyone troubleshoot their form without having a read only access to the designer. I usually won’t troubleshoot the actual form since it is too time consuming. That said when I’ve had issues in the past I couldn’t solve I usually just pay the 10 bucks or whatever it is and have the tectonic wizard build my form.php then I tweak it a little from there and it usually works.

Thanks for your input!

I will try!

Hi again!

Unfortunately it didn’t work. The problem seems to be that the e-mail will be sent no matter if the ReCAPTCHA is used or not.

I’ve removed the Redirect URL from Webflow, but it still redirects to the failure page, as it is defined in the script.

Can you tell me if I need to change something there? Or avoid the redirect?

I had to change from my clients server and rebuilt it in my own website, the read-only link is here: Webflow - FORCEFIELD

Thanks for any advice!