Streaming live at 10am (PST)

How to redirect http to https


#1

I turned on SSL and the website is hosted on the webflow-server, but my website is still showing up as HTTP. I want it to redirect to HTTPS. Could you help me out here?

Here is my site Read-Only: LINK


#2

Enbale SSL for custom domains (Paid plans)

This link works fine (Without any redirect):
https://clixx.webflow.io/

Clear cache maybe (“still showing up” where? on google index?)


#3

Hi @ElienR,

Thanks for letting us know about http not redirecting to https.

This is definitely odd behavior, as I was unable to reproduce the issue: https://cl.ly/12515f27f2f7

Would you be able to access your site in Incognito mode? As @Siton_Systems mentioned, you may be experiencing a cached version of you project.

Thanks in advance, and I’ll be standing by to test with you.


#4

Hi @mistercreate,

The redirect works in the incognito mode. However, the problem keeps occurring in the Chrome-mode, even when I deleted all the cache: when I enter the http in the browser it does not redirect to the https-domain.

The subdomain of webflow functions as our beta-version on which we will run a pen-test as soon we have this http-thing fixed. If that works we’ll publish it to the official custom domain, all under the same project, hosted as a basic-hosting-plan of Webflow.

Can you help me to fix this?


#5

You do this? ("the begining of time")?

image

I think you have little Misunderstanding - the io domain (Not “custom domain”).
https URL will work:
https://clixx.webflow.io/

And also http:
http://clixx.webflow.io/

The io is without a redirect (@mistercreate can you confirm this?)

Enbale SSL is under “custom domains” ( Only with hosting subscription ):

Summary:

Test your custom domain (Not .io). Work fine.


#6

Thanks @Siton_Systems, but this does not answer my question.
I did clear the cache from beginning of time. I know the https works, but it is the redirect of the http that is lacking. The io should work with the redirect as I have SSL enabled (as you can read in my first question). However, the redirect is not working.


#7

If this problem is only in your specific laptop in specific browser (chrome) - this is an issue of cache/history/cookies I don’t know.

AGAIN io will not do any redirect to https (only .nu + again the SSL enabled is for custom domains. The io is not custom domain).

Sorry i dont know how to help you. Talk with the staff (her) or open a ticket.


#8

thanks, I have created a work around with a copy of the project to be published on a custom domain that will function as the beta domain.