Streaming live at 10am (PST)

How to Remove Montserrat font?

We are working on some prototypes using Webflow, I like the product, but I’m having issues making the prototype actually load fast in mobile devices. There’s quite a lot stuff loaded that I’m really not using.

One case is the Montserrat font. On my font options, I only load the Roboto family of fonts:

Nevertheless, inside the developer tools the font is loaded in many resolutions I’m not even using.

Another issue from 2018 that is similar but didn’t provide an answer:

How can I get remove this unused font?

Are you 100% sure there are no classes in your build that use Montserrat? If you select it from the list of default fonts inside designer this would make webflow load full family.

Any way to check for this? If it was selected, we aren’t using it in any text. Is there a place to see the fonts being used?

I am afraid the only way is to go through your classes one by one. Don’t forget to clean unused classes just in case too

I was clicking clicking searching for fonts used. Couldn’t find it.

I used this advice on my website and it says I’m really not using Montserrat:

This is really annoying, and is specially annoying this has been an open issue since 2018. Is this in your backlog?

In all honestly this issue never happened to me (even when I was using montserrat and then removed it) so I cannot comment further.

This is our website:
https://www.cliptap.co/domakeup

Is this something we can open a support ticket for?

Why not?

Just in case - I don’t work at Webflow.

@Alejandro_Sanchez - You need to change the setting in the following class which is triggering the load of the font.

.default-state {
        font-family: Montserrat, sans-serif;
        font-weight: 400;
    }

Finally figured it out.

I discovered the button Clean all.
This gets rid of unused classes.

This reduced the loading time to mostly half! now gotta update some images :smiley:

Thanks everybody for all the help! :slight_smile: