Streaming live at 10am (PST)

How to remove the white space at the bottom of a site?


#1

How can I remove the white space at the bottom of a site? On the Slate theme, this is not a problem, but on Gallio it certainly is. It looks like this:


I just want the footer to be the same color all the way down and not be dark blue, then white. How would I add that? P.S. The white part on Webflow is the body.


#2

Find your Body and go to the css style magins.
Good luck!


#3

Hi Olivia, welcome to the forums! We add that space at the bottom of the body so that it's easier to add elements when your site already takes up the page. Be assured that it's temporary and it disappears when you click on Preview or when you Publish. It's just there to help you while you're designing.

Hope this helps!


#4

@Emilio_Escamill I tried that, but when you move the CSS margins around it does't do anything.
@thesergie When I publish the site/preview the site the white part doesn't go away. frowning


#5

Hmm that's really odd! What's our subdomain?


#6

mmmm share with me a "Troubleshooting Link" to check that..


#7

@Emilio_Escamill
https://webflow.com/design/apphover?preview=922251a8bb11a280b6fbe5b07d0a668c

That's the link, take a look at it.


#8

@thesergie Do you mean my subdomain? Well, if so then here:
http://apphover.webflow.com/


#9

Never mind - I think I fixed it by setting the body to the same color as the footer, and making the other things white, not transparent. Thanks!


#10

@Apphover it seems that you have bottom margin on your footer. Remove that property by clicking on it and removing it.

After doing that when i preview your site the white space disappears. Let me know if this works for you too.


#11

Hello, Sergie! how to remove this bottom margin? http://getswipe.ru/admin


#12

Hey @Andrey_Sharipov the reason you have that space is because you don't have enough content in the middle section to push your footer to the bottom.

But if you will always have barely any content (you want a full page site that doesnt scroll) I'd recommend a trick that @bartekkustra suggested:


#13

@thesergie But this page http://getswipe.ru/ have white space too.


#14

I don't see white space on that website. Which browser are you looking at?


#15

I am looking at Google Chrome.


#16

All my 10 sites have this white space in Google Chrome.


#17

Record your issue or post some screenshots with explanations of what white space you are talking about. I don't see any white space on site you've provided.


#18

Sorry for bumping, but I'm having the same problem.
It's set to zero, but when I hover over the "0" it's still showing a margin of 50.

EDIT: But no problem when I export and upload to a server. Still not OK in view mode though.


#19

We add white space below the last element so that it's easy to drag new elements onto the screen. That whitespace is added dynamically. We will probably have a setting down the road that shows/hides that whitespace.


#20