Streaming live at 10am (PST)

How to setup Webflow + SSL + GoDaddy

I have been trying to migrate my site to Webflow from Siteground.
Siteground has baked-in SSL that is on by default and simply works so I’m, spoiled.
Webflow doesn’t. :frowning:

There is all sorts of conflicting advice in the forums about whether Godaddy and Webflow play well together with SSL. Some say to use Cloudflare, etc. Others say’just do this!"

Weblfow’s own page says SSL Is is automagically on if your project was created after 14 Nov 2018, but mine wasn’t, so it tells my to simply turn it on! (which I have done… and saved)

I have been trying to get the DNS, A-records, C-name, etc. figured out and it’s just all broken.
My site will NOT load, in any browser.
I also get www.www. in the URL bar when I try to go to my site (in Chrome, FF, Edge).
Yes, I’ve cleared my cache, tried it on other computers, etc.

Here are my current GoDaddy settings:

And my current Webflow settings:

Lastly, this page in the Webflow University says: (I added the highlights because I have NO IDEA where the Webflow dashboard lets me set A-records)

Hi Charles,

Try the following and see if you get the desired result:

Change the following GoDaddy DNS records:
A @ 13.248.155.104 should be A @ 23.235.53.229
A @ 76.223.27.102 should be 104.156.81.229
CNAME www.charlesfineportraits.com (DELETE THIS RECORD)

Regarding the info you highlighted on Webflow University, the change is not made in Webflow, the Webflow Dashboard has the A records information listed as a reference. (Namely the Custom Domain image in your original post.)

Let me know how you get on, and we can sort out any other issues (if there are any)

Regards,
Keiran

1 Like

Hi @chuckw, thanks for your post and thanks @knk for stepping in to help.

As @knk mentioned, the extra WWW domain need to be removed, here is a screenshot showing the records that GoDaddy needs, this is not an automatic setup in GoDaddy:

In the screenshot originally shared from the dashboard it appears that the “Enable SSL” toggle has not yet been set, so the next step would be to enable that from the Hosting tab of project settings and then to set the WWW domain as the default domain:

The last step after settings have been updated is to Publish your project.

I hope this helps.

knk, cyberdave,
Thanks!

I’ve now set things up this way:

A @ 23.235.53.229
A @ 104.156.81.229
CNAME www.charleswaugh.com deleted.
SSL turned ON in ‘Hosting’ tab

I’ll see if it all propagates by tomorrow morning.

A question (well, two):
Why those values for the A-records, when the Webflow page tells me different (which I had in in the orig. screenshot)?
And why do the values knk suggested not match the values in the screenshot supplied by cyberdave?

Charles

WOW!
That was fast!
It pops right up!

BUT…

The URL is charlesfineartportraits.com (which is no big deal to me, I don’t care if it’s the www. or not)

BUT…

Chrome says it’s ‘Not Secure’ - i.e., no SSL, no HTTPS://

: - (

Maybe the SSL takes time to ‘fire up’?

Charles

Here’s a screen shot of my Project Settings page:

BUT…
I can report that everything else is working all peachy-keeno (to quote my late mother’s favorite happy-phrase)

Hi @chuckw,

The IP addresses that @knk gave you are the IP addresses to the non-ssl servers, @knk was responding to the fact that your original screenshot was complaining about the IPs not pointing to those servers, but that was because SSL had not yet been enabled on the site.

I would recommend to use SSL if SEO is important as Google indexes sites with SSL but either does not index or will be removing sites without SSL from the index.

The screenshot I sent with the godaddy IP addresses are the ones you need for SSL:

Currently however, the site is still pointed in DNS to the old IP addresses which need to be changed, see here from a public dns settings lookup:

Those A Records starting with 23 and 104 need to be changed to the SSL IP addresses which can also be viewed on the article on how to Troubleshoot your DNS settings.

Once the IP addresses have been changed in your dns settings, make sure to set the WWW domain as the default domain, this is required when using GoDaddy as your dns registrar:

Once those changes are made, the last step is to Publish your project

I hope this helps, let me know if any questions.

@chuckw, an update, it looks like you have successfully configured the domain, good job :slight_smile:

cyberdave,
YIPEE! SHAZAMBO-WAMBO!! HOOT-N-HOLLER!
[insert other expressions of glee and thankfulness here]

Thank you, it’s all workin’ now.

Though…
The URL shows no https://www. until I click ont eh URL, then it pops open and shows it.
??

Curious…

BUT: IT WORKS! IT WORKS!

Thank you.

Charles

Hi @chuckw, with the WWW domain set as the default, any user who uses just the root domain without WWW will automatically be redirected to the WWW domain.

That WWW domain will show in the url bar, but your site visitors can use either version of the url to access the site.

I hope this helps :slight_smile: