Streaming live at 10am (PST)

How to use IPv6 address to point to Webflow?


#1

Hello Guys!

I'm in a bit of panic because i have hosting problems with a client of mine. I made a fully functional CMS-Site, the client was happy and i activated the CMS-Hosting. I let the old webhoster do the DNS changes for me as described in the tutorial (he is in possession of the domain name but is very cooperative) and it worked just fine for everything i could test. Webflow says the connection is established and the website shows correctly on all the devices i could get my hands on.

BUT then i wanted to show the client how to edit the site via the Editor and i wasn't able to get the new Website showing, ironically exactly on the computer my client wants to edit the site on. It always linked to the old site. I deleted the cache, restarted the router, the computer, flushed the dns-cache until i didn't know what to do.

Now some days later more and more selective people say they are unable to see the new site and just get to the old one. After getting in touch with the old webhoster again he mentioned that this could be because of webflow only establishing an IPv4 connection but not an IPv6 address and his and some other people have IPv6 connections and because there is no entry for IPv6 on the DNS-Settings they get the old address.

Could this be the Problem? And if yes how do i fix this? I couldn't find any IPv6 address for Webflow.

The site i am talking about is www.theaterfreunde-wiesbaden.de and i would be very happy if anyone could help me here!

Thanks in advance,
Sebastian


#2

@sebastianhoerz I'm not sure if this helps Sebastian, but I'm getting the Webflow site when I click on the link.


#3

@fsociety79 Not really right now :slightly_smiling: Only some People have the Problem. But do you have an IPv6 Internet connection? You can test it here http://test-ipv6.com


#4

You have totally different content via IPv4 and via IPv6.

To compare disable/enable

network.dns.disableIPv6;false

in firefox via
about:config

and refresh

Assumed your client has dualstack-connection, otherwise you can not switch between the protocols.

Description via IPv4: fullscreen picture, scroll down "Termine" http://theaterfreunde-wiesbaden.de/#anfang

Description via IPv6: small picture in the middle "enter", http://theaterfreunde-wiesbaden.de/start.htm

I don't know what is old, what is new.


#5

@thomasschaefer I thought that would be the problem! thanks for helping me proof it! But sadly i don't know what to do now. The DNS has a 2x A-Record Entries directing to Webflow and a AAAA-Record Entry to the old server.

But i don't have any AAAA-Record for Webflow and a friend of mine told me that i can't simply kill the old AAAA-Record because then the site will stop working for IPv6. :confused:


#6

Hi @sebastianhoerz, Webflow is using IPv4 addresses only right now.

From a Webflow perspective, we are not requiring the AAAA record to be set, I wish I had an easier answer for you.

Maybe one thing to look into, is checking out cloudflare https://blog.cloudflare.com/introducing-cloudflares-automatic-ipv6-gatewa/

I hope this helps. When more info for using IPv6 is available, I will update.


#7

At the moment you have no choice. If a hoster has no ipv6 you should remove AAAA.
A misconfiguration of ipv6 is worse than missing ipv6.
The next time you should consider the right hoster before you move.


#8

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.