Streaming live at 10am (PST)

I published my WebFlow site and now I Can’t send or recibe emails on my company mail address

Hey there, I’m using WebFlow and everything is fine until I published in my custom domine, after that I can’t send mails or use my email it says 0x80040900 error.

Any thoughts about this, or how to fix it I’m using HODE as mailing provider

Look at your DNS settings. Sometimes MX records a set to the @ domain record and if so following the instructions on setting up a custom domain will adversely affect mail.

If you at least shared the domain name we could look at the DNS to try to help you.

Jeff S, thank you for answer, my domain name is espressoamico.com

Your MX record points to the host mail.espressoamico.com but it appears there is no A record nor CNAME record that resolves it.

Contact Godaddy (I believe you are using them) and get assistance.

;QUESTION
espressoamico.com. IN MX
;ANSWER
espressoamico.com. 3599 IN MX 0 mail.espressoamico.com.

;QUESTION
mail.espressoamico.com. IN A
;ANSWER
;QUESTION
mail.espressoamico.com. IN CNAME
;ANSWER

Thanks for that, im a beginner here, so let me check if i get it correct.

i have to add a DNS like :

and modify the mx for something like this?

Sorry for those dumb questions.

NO. If your @ records are pointing to Webflow you don’t want to use them for mail records since there is no mail server there. Your mail provider either has an A record IP address they provide for you or a CNAME record to use. See your mail host provider for details.

I contact the GoDaddy support here in México, they don’t even know what is WebFlow haha.
A guy from GoDaddy told me that the configuration looks “ok” for him that it has to be the app I’m using, but he sent me this:


Those are the ones you said, right?

Hi Jeff, I have made some changes.
Now I can log in perfectly and send mails but I can’t get any mail. Only if it is coming from another espressoamico.com mail address.

i have add:

A - mail - the IP from CPanel
CNAME - webmail - p3plcpn…net
MX - mail - mail.espressoamico.com

Any thoughts about this.

Mail servers cache DNS lookups. You might have to wait for 8-24 hours. Then check. Mail gets queued up when it can’t be sent so i usually is not lost.

I hope this fix it … so now I just have to wait for it… I think this is the worst part of it hahah