Streaming live at 10am (PST)

IE - disable compatibility mode for intranet sites


#1

I did a site in Webflow and looks great in Chrome....looks OK in Internet Explorer, BUT the input fields stretch vertically (looks like height is doubled) and select boxes stretch horizontally....only input fields have this display issue.

If I uncheck "display intranet sites in compatibility mode" in IE, it displays fine. So basically it's only messed up in IE compatibility mode.

How can I do this in code? I've tried things like:
<meta http-equiv="X-UA-Compatible" content="IE=10,9,7,8" />
<meta http-equiv="X-UA-Compatible" content="IE=EDGE" />

But that doesn't seem to work....I am using IE 11, but this also happens in IE9...Strangely, IE Edge works fine...

Any thoughts?


#2

You cannot have duplicate meta tags with same "http-equiv", plus you only need to specify the lowest version number.

https://msdn.microsoft.com/en-us/library/jj676915(v=vs.85).aspx


#3

I didn't use both lines at the same time - I was just showing the different ones I've tried....

And I've tried single versions as well, like:
<meta http-equiv="X-UA-Compatible" content="IE=8" />


#4

If it's messed up in compatibility mode, then why are you asking users browsers to display it in IE 8 compatibility mode?


#5

Well, I can't seem to make it display correctly no matter what I try....the only way it displays correctly is if I go into IE compatibility settings and UNCHECK the option that says "display intranet sites in compatibility mode" - so this basically turns OFF compatibility mode....then it looks fine...

But obviously I can't do that for users browsers - so I'm trying to find a way to force compatibility mode OFF for Internet Explorer....

I should mention this IS on my company's intranet....


#6

Your title was unclear, I have edited it.

It is possible to override the compatibility mode in intranet.

These will explain and the answers will solve your problem:


#7

Thank you! I will try it tomorrow at work - I know that it was not the 1st meta tag - maybe that was the problem.


#8

Wow! That was it! Thank you!


#9

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.