Streaming live at 10am (PST)

IE9 and IE10 support for published websites will soon be deprecated on March 1st, 2016


#1

IE9 and 10 support will be deprecated on March 1st, 2016

On January 12th, Microsoft officially ended support for Internet Explorer versions 8, 9, and 10. You can read more about that here:

These old browsers lack support for many new web technologies, and won’t receive any further security or functionality updates from Microsoft — so their continued use should be considered insecure and, in some situations, flat-out dangerous.

Therefore, starting on March 1st, 2016, Webflow will no longer actively maintain IE8–IE10 support for features on published Webflow sites (things like sliders, dropdowns, tabs, interactions, etc).

The good news is that this frees up the Webflow team to work on bleeding-edge web features a lot of you are waiting for, like flexbox, calc(...), and responsive images. :smiley:

If you have clients who still demand that their sites (built with Webflow or not) work in these unsupported and insecure browsers, please let us know. We want to understand these use cases to help us make better decisions in this area.

(All existing browser-compatibility code Webflow offers will stay put, but we won’t devote any further engineering efforts to backwards-compatibility with any IE version below 11.)


Webflow sites are now published with jQuery version 2.2.0
Webflow has flexbox now!
IE Compatibility failed
Webflow has flexbox now!
#2

Hi Vlad, it is not an easy thing to change browser versions for all workplaces in big companies. Especially old sharepoint versions etc. sometimes need old IE versions. So it is good to keep all browser-compatibility code in place.
best
kalli


#3

@Kalli2000 I have to politely disagree, by providing support we are just 'enablers' to the problem.


#4

True, but I'm supporting this "kill-stupid-IE" effort. Makes a good case for me and my colleagues to convince lazy ass developers, IT managers, and other idiots to finally upgrade their shits.


#5

hallelujah! bye IE9-10 welcome flexbox!


#6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
Please create a new linked topic if you have further questions.