Streaming live at 10am (PST)

Iframe 3 scroll bar


#1

Hi
I put an iframe on my page and I would like to know how to keep only one scroll bar on my page.
http://ge-lacombe-photo.webflow.io/espace-clients
https://preview.webflow.com/preview/test-iframe?preview=8c42f2f25cc1a55afea62df687b3d083

thank you


#2

Hi @nadine

Select your Iframe holder DIV and set the overflow to hidden:

Secondly, edit your embed code:
crolling="no" should be scrolling="no"

Using Iframes however will never get perfect results... But at least you can get rid of those scrollbars :slight_smile:


#3

Thanks for your help !
I realize I do not have the choice to keep the scrollbar on the iframe because the bottom of the page is cut on my iphone. Is there a way to remove the scrollbar between the iframe and the page and keep only two scrollbar? or maybe the problem is my browser, do you see 3 scrollbar on your computer?
My English is not very good, I did the translation with google I hope this is understandable.


#4

Indeed I also see 3 scrollbars.

For the 2 scrollbar options: Set the "iframe-holder" DIV back to Overflow visible and set the height of the DIV to auto.
Next, remove the scrolling="no" option from the iframe code.

This should get you back to a 2 scrollbar option.


#5

I put auto on the div and in the code and overflow visible. It still does not work. I'm not familiar with code so i copy the code from Waldo template Responsive Full Width iFrame.
maybe is the first part of the code the problem, it`s commun to reapeat the width and height?


.iframe-holder {

width: 100%;
height: Auto;
-webkit-overflow-scrolling: touch;
overflow-y: scroll;
}
.iframe-holder iframe {
height: Auto;
width: 100%;
}


#6