Streaming live at 10am (PST)

Image not showing on published site and page load issue


#1

I have an image that is not showing on my site when viewed on an iOS device. It's down in the contact form area.
My site is: http://glen02.webflow.com

Also, I was wondering what would make a page load at the bottom rather than at the top. Earlier today my site was actually loading at the bottom when I was checking it on my iPhone. It seems to have worked itself out now, but I was just wondering what was causing that.

I am new here and I know I will have plenty of questions. lol, but I will do my best to also interact and help you guys out with things that I know. Take care.


#2

What's the resolution of the image? Also what's the size? iOS has limitations. Might be it.


#3

It was around 4900x2500 but I have resized it. I thought that I had done that already. But, even after uploading a smaller version the issue was still there. I messed around with the position and the cover / constrain to make it show. However, now the image scrolls with the page even though it's set to "fixed". I don't know what to do now. Again, this is happening on iOS.


#4

Your bg image shows up for me on iOS. Must be your cache. Empty all caches in Safari settings or try with Chrome.


#5

Also there's something weird... your top banner image is quite huge and heavy so it takes times for it to load. In the meantime, the temporary Webflow-designer pattern image is shown.... and it's still declared in the code.

@thesergie is this normal?

.slide-1 {
background-image: url(https://daks2k3a4ib2z.cloudfront.net/54bfb65c816f6ac32c53aec1/54c6fccfa77a2c8d1a194be2_slide-1.jpg), url(https://d3e54v103j8qbb.cloudfront.net/img/example-bg.png);

Edit OK I got it, it's easy to reproduce. If we click on Add a background image then do nothing, the property stays with the example image delcared as a background. It's easy to add a new background and not notice the default one is still active underneath.

@GodlessGlen you should delete the extra background:


#6

Hi @GodlessGlen, to add to the good advice from Vincent, I believe the reason your page was loading at the bottom was because you had the autofocus checkbox turned on for one of the fields. You might check this, if you still continue to experience the issue.

Cheers, Dave


#7