Streaming live at 10am (PST)

Images in 'settings/cog' tab "auto" proportion won't work


#1

If I have a square image and type "500px" for width of height, it will stretch that 1 proprtion:

If I leave the other proportion blank or 'auto', nothing happens. It does not auto proportion.


#2

Can you please share your read only link, this will help us diagnose the problem much faster. Thanks! :wink:
http://help.webflow.com/faq/how-do-i-share-my-sites-read-only-link


#3

https://preview.webflow.com/preview/tol-revamp3?preview=d1e1aab28f9149fa6fb869aacca2db0b

Note the image in the middle, with the right side: it's a square image, I set the height, and the width does not reflect.

EDIT: OH I just realized... it's a width issue. Width even at 10px will not change to 10px:

EDIT 2: But 10px will genuinely be 10px if height. Why would it only allow me to do this for height?


#4

The correct way to do this for multiple image sizes as backgrounds, is to use background image. Images have a max-width of 100%, so if you set a height, the width cannot expand further and thus it stretches.

The background size can be set as "cover", which will solve your problem.

If you want to use an image component, you will need to upload the exact sizes you want to display them at, without modifying the width and height further.

This is intended, and is not a bug.


#5

Why wouldn't I be able to alternately just allow the size to be bigger and turn overflow off? This not very intuitive - Why not have the option to do both? Should have the options grayed out if it doesn't do anything or block the size going higher (if height > img height then height = max height)


#6

Of course you can do that, just give the image a class, and you will be able to override max-width to "none". As for why this is the default, I'll leave this to designers to answer. It's probably to do with responsive design practices.


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.