Streaming live at 10am (PST)

Implementing JQuery twitter plug in


#1

I'm having trouble implementing this JQuery plugin that I have found to load a twitter feed.

http://www.tweecool.com/ this is a link to the plugin I've been trying to install on my Webflow site, however the pages doesn't load anything and I have followed the instructions directly on the Tweecool site

https://webflow.com/design/leedsjuicery?preview=213dcbf74e719276d9424efad9ca107d

any suggestions as to why this might not be working?


#2

Hi @thomassquire, thanks for your post. I took a look, and I can see at least two issues. First issue is that you have one line loading jquery in your head. You can remove that, because we have jQuery included in Webflow sites already. Second, copy the script code and paste in your Footer. See my screenshot as a reference what to change and move to footer and then save all changes.

Third, select your twitter feed element, and give it an id equal to the ID in the script "tweecool" (enter the id without the quotes into the ID field) see my screenshot:

After all that, republish your site.

I hope this helps, let us know how it goes Cheers, Dave smile


#3

Hey Dave! Thanks for the super speedy response, so i've made all those changes, however it's still not working?

I'm getting these errors in the Inspector I don't know if that helps at all?

Many Thanks


#4

Hi @thomassquire, thanks, sometimes troubleshooting these things is a process. Fix one thing, check if it breaks, fix something else, check again.

Could you restore that one jQuery line that I instructed you to take out. I think this plugin must have a jQuery dependency. After adding that back, then republish and see how it works. It might have just been the missing ID.

I will take another look, and get back to you as soon as possible. You might take a screenshot of your custom code or copy and paste it here in the forum, and let others see how that is setup. The public read only link to the site, does not let people see the custom code setup. Cheers, Dave


#5

Hi @cyberdave ,

So I tried reinstating the jQuery line, however still no luck. I've somehow managed to remove on of the errors though, so I'm only now getting this error.

Here is a copy of my current custom code set up

Thanks again for your help!


#6

Hi @thomassquire, thanks for yoru update. Could you try this, move the two script lines that are in your Header, to the Footer. Insert those before the existing scripts.

See my screenshot as a reference:

Try that, then republish. I hope that helps, let me know how it goes. Cheers, Dave


#7