Streaming live at 10am (PST)

Impossible to use dash in CMS uri path '-'


#1

It’s impossible to use dash in CMS uri path '-'while typing the path,

to reproduce error

Create random CRM collection with 5 CMS Pages.
Type the following into the uri path of each CMS page URI
/one-two
/three-four
/five-six
/seven-eight
/nine-ten

^^
You can type ‘one’ but you cannot type ‘one-two’ - instead what is typed is onetwo, and then I must manually insert ‘-’ between ‘one’ and ‘two’ to make ‘one-two’.


#2

Hi @miekwave if you use the spacebar it will automatically create the dash for you. We have an open issue for adding the actual - to the list of accepted chars there as well, but for now using the spacebar should help :slight_smile:


#3

Thank you, I hope in future this is patched


#5

Hey @miekwave! Good news :slight_smile: This should be working fine by now. Let us know if that helps :slight_smile:

Cheers,
Bart


#6

@bart
On test as of this post the dash does not work

see screenshot
image


#7

It works. The notification there is for you to make sure to set up 301 redirects as previous links that might have had some SEO juice working already will break. So if your old url was

snakesonaplane

and you want it to be

snakes-on-a-plane

make sure to set up a 301 redirect in site settings to point as following:

/snakesonplane/(.*) → /snakes-on-a-plane/%1

Magic huh? :stuck_out_tongue_winking_eye: But it works :slight_smile: lmk if that’s working for you as well. You might want to refresh browser (ideally clear cache just to be safe).

Cheers,
Bart