Streaming live at 10am (PST)

In Page Linking not working?


#1

I have scoured the Forum looking for a solution to my In-page linking not working, I have followed multiple tutorials and suggestions but none of them have worked?

Check it out if you can: http://manor-house-school.webflow.io/services/for-schools-and-nurseries
The FAB in the bottom right corner is the Flyout with navigation.

P.S it works in the Webflow Preview Mode but not on export.

Thanks Aaron.


#2

Hi @Aaron, Thanks for the post.

Could you share the site read-only link: http://help.webflow.com/faq/general/how-do-i-share-my-sites-read-only-link, and the published site where the in-page "section" linking is not working? It would also be helpful if you can let us know which link and what the target section is for the link. Cheers,
Dave


#3

Hi @cyberdave,

Thanks for getting back to me. Here's the link: https://preview.webflow.com/preview/manor-house-school?preview=e3e97e2fb15d96aad3b8119162afe3d8

And here is the published site and page where it is not working http://manor-house-school.webflow.io/services/for-schools-and-nurseries

The Icon in the bottom right has IX applied to it, it contains the navigation for the In-page links, every "Row" has its own ID I wanted each link to go to. Let me know if you need any more details?

Thanks a lot, Aaron.


#4

Hi Aaron, thanks a lot for the followup smile The first thing to check in these cases, is the published page and see if there are any javascript errors. If there are, this causes all other scripts on the page to not execute properly.

I checked the published site, and in Chrome, I right click on the mouse on the page, and choose Inspect Element. From there I click the console tab, and I can see there is a script error, so that has to be fixed first:

In looking at the error, I can see that the script is trying to execute, before jQuery has loaded. I would move the custom code in your Header, to the Footer, because jQuery is loaded in the footer also, and any scripts in the Footer are executed after the jQuery has loaded.

​I hope this helps. If not, please let me know – I'm happy to assist further! smile

Cheers,
Dave


#5

Hi thanks for Debug tip learning a lot smile I use it for CSS and HTML stuff
but not really experienced with JS.

You were right it is the custom script which controls the smooth scroll
interfering have removed it for now and it works thanks very much Dave!

Aaron


#6

That's great @Aaron. Welcome to the club of learning more everyday about Webflow smile I am still learning and I hope we can continue to learn together smile Cheers,
Dave


#7

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.