Streaming live at 10am (PST)

In production, a mobile anchor link scrolls too far

For my site, I was able to have a nav link become an anchor link to go down to the “Sponsor” section of this page: https://futureplace.builderonline.com/. However, when I had multiple people using a mobile device, they all said (and I experienced this too) that the anchor link scrolls too far, past the beginning of the section that I cited.

I tried this in chrome, incognito mode in chrome, safari, and two other users experience the same issue. In webflow preview it works fine, but only in production does this happen.

Any help would be appreciated!

Hi @DK_LA!

Would you be able to share the preview link so I can help troubleshoot this with you?

Thank you,

Sean

Hi Sean!

Thank you so much for helping! Here is the preview link: https://preview.webflow.com/preview/future-place?utm_medium=preview_link&utm_source=designer&utm_content=future-place&preview=04fe4d457e5ba9d9f5c9654c05671054&mode=preview

Alright so you use a modual and a normal sponsors section which is fine and the way you can link to it correctly is if they have the same anchor name. So for instance in the first photo I named both of them Section-Sponsors. Then I went up to the sponsors and made sure it was referenced to that anchor name like in the second photo.

If any of this doesn’t make sense or you need more help let me know :slight_smile:

Sean

It was the ID! I had to set the section ID to a name. Thanks so much for your help!!!

1 Like