Streaming live at 10am (PST)

Inconsistent Navbar Interactions

Hello,

Background:
On my Webflow website, I created two pages: One in Spanish and the other one in English. On each of these pages I created a Navbar Symbol (one for the Spanish version and one for the English version) with various interactions. When you land on either page, the interactions on the Navbar work fine.

Problem:
However, when you click on the language URL in the Navbar, the interactions get messed up on the page you’re redirected to. It appears something gets modified in the interactions when you are on the other page (English/Spanish)

Steps to reproduce:

  1. Preview the site on the designer (notice how the navbar interactions work)
  2. Click on the English or Spanish navlink
  3. Notice how the Navbar now looks different and doesn’t have the same interactions as the other navbar

Note: When I change the Navigation Interaxction for the Spanish Navbar, it appears the interactions on the English Navbar get modifiied.

I’d appreciate your feedback on how this issue can be resolved. Below is the URL to my Read-Only site:
https://preview.webflow.com/preview/capitaltec-website?utm_medium=preview_link&utm_source=designer&utm_content=capitaltec-website&preview=da37b57bb59a51e210ee2f1a187d13ed&pageId=5d6fdc2c00df0712074c89cd&mode=preview

Thanks,

Horacio

Which interactions do you mean? There are none that I can see aside from the scroll interaction which looks pretty much the same on both pages

I’m referring to the “While page is scrolling” Navigation Animation. There are interactions for Background Color, Text Color, and Size. Please take a look at the following URL with a video that shows the issue:

Thanks again for your help,

Horacio

While your video is uploading can you check if the same behaviour happens when you look at the actual published site?

OK, saw the video. You are not supposed to change pages that way. Just change them through the designer menu. On the published site everything will work as intended.

1 Like

Hi Dram, what do you mean change pages through the designer menu? what designer menu are you talking about? Thanks for your help

The one inside designer, where you create and select the pages you’re working on.

The reason for them not working is because the initial states are not being processed correctly while in preview. But visiting both your main pages through the default pages menu and then previewing then you will see it works fine.

1 Like

Just tried it and it works! I didn’t know the initial state were not being processed correctly.

Thank you very much for your help! I just published my changes and they all look good on the live site: https://www.capitaltec.com.mx/

1 Like