Streaming live at 10am (PST)

Incorrect A Record in DNS causes incorrect routing of http request


#1

Hi,i published my site with my own domain name, sometimes it works and sometimes it gets directed to domain host ,should i contact my host domain provider or something wrong within webflow? thanks in advance.

http://melodyminds.com (now it works)

When it doesnt work it shows this host page : https://misshosting.se


#2

dns bounce. not really an issue unless this happens 3+ days after you make the dns changes.

basically... the route to your website is not fixed.

your visitors transit could go from where they are to point Z. to point X then finally to your old site.

or. the visitors transit could go from where they are to point H. to point S to point M then finally to your new site.

When all the dns severs are updated... this shouldn't happen (but it can take up to 48 hours depending on your provider). Until then - you and your visitors could encounter some propagation issues ie: dns bounce.

https://www.siteground.com/kb/what_is_dns_propagation_and_why_it_takes_so_long/


#3

@Revolution Oh okay thank you,the DNS has been set for few days ago but i officially published it today,does it means that the counting starts today and 3+ days or 48hours?

Now it stops working again :frowning:


#4

no. dns doesn't affect publishing - and vice versa. dns is done at the various servers world wide. There are literally 1000's of dns servers. I have one sitting right next to me. And a couple in Utah, Texas, Florida, and Illinois.

Publishing is done via the webflow servers.

If you use the .io address... mysite.webflow.io.. then you are calling the website directly.

If you are accessing your site via mysite.com... with the dns servers... the dns servers are redirecting you to webflow.io - which then redirects you to mysite.webflow.io.

If this issue happening 3 or more days from the time you switch the dns settings (at your host or registrar) then you probably need to contact webflow support.


#5

If you are worried - try using a proxy server.
like https://hide.me/en/proxy

enter your domain name - http://melodyminds.com/ (not the webflow name)... and see where it goes.

this will take you to your website from an alternate ip.

When I use the proxy server... I see your old website. Which means the route the proxy server took - has dns servers that are not updated.

When I direct connect... I see the new one.

So far. I wouldn't worry. Give it another day or so.


#6

Yes it has been 3 days since i switch.

I tried different countries and they all pointed me to my host provider :neutral_face:


#7

Then it's just a wait and see game. Here in the US... dns refreshes are completed pretty fast.

Every update I do is generally done before I can think about it.

But even in the US.. it depends on your host - and the domain TLD.

Outside the US is sometimes "iffy", It could fast you are in Germany, France. UK. etc...

In the past - I've seen updates for the Czeck Rep take a week. Max time it's suppose to take is 48 hours.

We manage and host our clients on our own dedicated servers... all on Tier 1 10GB fiber... so we never have to wait.

My own line to the net is a 50mb continuous business class fiber. That's why I often use proxy servers to check "real time". With my line - you can't really "check" what's really happening.

Just give it a little time... or try to get webflow support involved if the wait takes to long.


#8

Alright i'll give it some more time,just alittle worried since it is the first launch of a subscription base site so you won't get a second chance so easily :sweat_smile:

Anyway,thank you so much for you help @Revolution :grinning:


#9

following up on this.

Your DNS is pointing to the old host.

It wasn't last night... so I' guessing you switched it back.

Now - visiting your new site - takes you to the old host... regardless of your proxy.


#10

I havent changed anything,i get to visit the new site but not from german proxy wich direct me to the old host.
Does it affect when i unpublish and re-publish the site everytime i make any design changes?


#11

Hi @Linescape, thanks for getting back in in touch. The issue seems to be, that while the A Records are pointed at Webflow ok, there is also one extra A Records marked below, that should be removed, which is still pointing at the old host.

This results in sometimes the site hosted in Webflow to show, and other times the old host.

Remove the A Record for 185.76.64.20 and then things should be ok.

I hope this helps!


#12

@cyberdave Ohh yes now i see 3 - A records of melodyminds.com and removed the old one you suggest.
Hope it works, Thank u so much!


#13

This topic was automatically closed after 60 days. New replies are no longer allowed.