Streaming live at 10am (PST)

Interaction 2.0 within slider help


#1

Hi, I have an interaction added to text within a slider. When the slide changes to slide 2 I want the same interaction to happen on the text within side 2.

As the interaction is a page load interaction I am unsure how to add this to the second slide, it only words on side 1.

Any help would be appreciated.

Scott

https://preview.webflow.com/preview/klipp-it?preview=967aa8e32b01cf0ff073aa39a956566c


#2

Where is the slider in the site?


#3

HI, it’s on the home page.


#4

You said text within a slider on homepage. I don’t see a slider on homepage, to click or slide anything.


#5

It is a slider on the homepage, there is no arrows or clicks. It is simply a slideshow of 3 image backgrounds that fade in and out and with different text on each slide. Look at the navigator panel you will see. Make sense?


#6

Oh Oh I see what you mean. You need to create the interactions on the “Slider” element in the interactions panel, but it’s not active in the list until you click on the slider in the Designer.

@scottalexwatson-3


#7

Then when you add it on the Slider Into View… when it shows Slide 2… the animation of text will start :grinning:

Here’s a short video snippet of it… of course I can’t save it but you can see. And it’ll be once on slider view:

https://drive.google.com/open?id=1z1TqhLNcs7AfOpakmEqNYUVgaywIoM_b

Not the best quality video, but you can see it. Dang, I need find a better video player.


#8

Hi Gary,

Many thanks for your help and apologies for the late response.

I have it working now, however it only seems to work on slide 1 and 2, even though slide 3 has the same settings applied.

Also I have checked the loop box, however it doesn’t loop, only shows the interaction once, Any advice?


#9

Hmm, glad that part worked. Regarding the loop, it’s done in IX2 right? That loop check box didn’t work?


#10

Doesnt seem to have worked.

Also the interaction is only working on slide 1 & 2. Slide 3 doesnt work, even though I have applied the same interaction as 1 & 2


#11

Does slide 3 have a unique class name? Try deleting it and see if all works. Then add a new one with unique class. But don’t use replace elements in the interaction. Try adding the interaction on its own.


#12

TRied all that, no joy.

Interestingly enough, if I click the eye icon while slide 3 is in view the interaction works but then slide 1 and 2 dont work.

I think it may be a bug with the slider, as the interaction will only play on each slide once. Ans still slide 3 wont work if I click the eye icon on slide 1.


#13

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.