Streaming live at 10am (PST)

Interaction Bug on Root Elements

There seems to be a new bug in the interactions, Whenever I tried to animate a root object i.e text or image, the interaction doesn’t work, however once I wrap it in a div it does. The preview (in the interaction panel shows the animation) however the main site preview or published does not. There is no conflict with initial state or anything else. its seems purely related to a root element.

Note: all these elements are inside grids.

This happens on while scrolling, when scrolled into view and onload I have tried everything to stop this bug.


Here is my site Read-Only: https://preview.webflow.com/preview/amenity2019?utm_medium=preview_link&utm_source=dashboard&utm_content=amenity2019&preview=e39274ceca2a0c967838183f1c7efbeb&mode=preview
(how to share your site Read-Only link)

Please tell us where to look for the misbehaving interaction.

Take the header for example, there is a rich text block called header-title, inside the onLoad interaction this should fade like all the other elements do however they don’t.

When I try to add while scrolling to say parallax the images at the bottom they don’t work unless I wrap them in a div. (I had to remove that as this is a current build and we can’t have it all broken)

Looks like you are affecting the same element with different interactions. Just make sure that you are affecting one element with one kind of interaction only once. If you need to affect it with two different animations you ahve to wrap your element and target that wrapper (that’s why your ix works when you target parent). Try to go through you interactions and see where else you are affecting the element which doesn’t work.

That’s odd because they all have individual class names

I think you misunderstood. It doesn’t matter what names your elements have. The problem you are affecting the same elements with different interactions.

Your cta blocks have interactions that affect the same element. Change them to affect other items (by creating wrappers for the necessary elements as I have suggested). To see that I am correct delete interactions from your cta blocks and your onload will work.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.