Streaming live at 10am (PST)

Interaction only happening once


#1

Hey there!
How are you doing? :slight_smile:
I’m new to webflow and I’m facing a problem with the interaction of my slide menu.

Here is what’s happening:
If you go to the Bio page, and hover over the nav link ‘Produtos’, a vertical menu slides in. And from this vertical menu, if you hover over the first option (‘logan (novidade!)’), a second vertical menu slides in. Both menus are supposed to disappear when you hover out of the first menu. So far so good.

But after they disappear, if you attempt to do these same steps I described one more time, without switching pages or anything, the first menu slides in without a problem, but the second one doesn’t. After the first time, it never appears again. And when the second one stops appearing, the first one shows a bit of resistance in disappearing on hovering out… sometimes you have to hover in and out of the slide in menu a few times for it to go away. Any ideas why this is happening?

Thank you in advance for you help,
Nina

Here is my public share link: https://preview.webflow.com/preview/primeiro-enxoval?preview=648e18f88e948f70d91b1c5bed548444

Here’s the link of the published site for testing: http://primeiro-enxoval.webflow.io


#2

Hi @Nina_Grillo

Thanks for posting. I tested on this end and it looks like the animation is consistent on the live site when using the latest version of Chrome on Mac OS X 10.

Were you able to resolve the issue?


#3

Hi @Brando!
Thank you for your reply.
I wasn’t able to fix it… I am testing right now on the live site on the latest Chrome version on Mac OS X 10 as you said, and the problem persists… The animation of the first slide in menu is consistent, but the second slide in menu only appears once when hovering over ‘logan (novidade!)’. And after that it only appears again if I refresh the page.

Help :confused:


#4

Hi @Nina_Grillo

Here is a GIF showing what I see on this end on the live site: https://cl.ly/3d2l3m253l2S

And here is preview mode: https://cl.ly/1z0a3C1Y0L04

can you send a video / gif of what you are seeing on your end?


#5

Oh wow @Brando! It really works on your end…!

Here is a GIF of what I see here on the live site: http://recordit.co/fF7OiXjIqd
On my Preview Mode, exactly the same happens.

I have just tested on another computer, and the problem persists.


#7

Thanks for making that video – this is definitely bizarre.

Can you please try the following:

  • Try to reproduce the error while being logged into Webflow using Incognito mode with browser extensions turned off
  • If the problem persists, please take a screenshot of your Console and send it to me

Could you also please let me know what browser version you’re using by sending me your information from this page?

There should be a small share link when you visit the page which you can send to me.

Thanks in advance!


#8

Hey @Brando,
just tried what you said both in Chrome and Safari, and the problem still persists.

Here goes the screenshot of my Console:

And the browser info of both browsers:
Safari - whatismybrowser.com/w/2EKPCPZ
Chrome- whatismybrowser.com/w/7Q8G6XL

Thanks for the help!


#9

@brando @Nina_Grillo

I’m not entirely sure this is a bug or down to browsers. I think this is down to screen size and the interaction set up. Something to do with the last slide in not being hidden properly on the hover interaction. There is no hover out interaction on the Logan button and I can’t see how that div block is being hidden.

CloudApp

Nina, my guess is you’re using a smaller screen than Brandon. I’ve just tested this on my MacBook 13" and got the same result as Nina, yet on the 27" screen I’ve not had an issue.

@Brando, tell me if I’m way off the mark… I’ll keep playing!


#10

@markos84uk

I think you may be right on this! :slight_smile:

@Nina_Grillo can you try adding some hover-out steps to the interaction to see if this helps?


#11

I hope this video is easier to explain @Nina_Grillo

CloudApp

Just to add, I love the menus too! Beautifully done.


#12

@markos84uk :clap: :clap: :tada: :tada:


#13

:joy:

giphy-3


#14

OMG! @markos84uk and @Brando thank you guys SO MUCH for your help and persistence! This issue had been haunting be for days, and now suddenly problem solved!! Can’t believe it!

And @markos84uk thank you so much for the video, it was very nice of you and made my life a lot easier! Glad you liked the menus :blush:! Now they’re finally working properly…!
Cheers and thanks again :heart: