Streaming live at 10am (PST)

Interaction stop working when adding 'Affect Class - Only siblings with the class'


#1

Hey all!

I’m working on a accordion menu (or custom accordion if you like). Everything works perfectly until I add ‘Affect: Class’ and then ‘Only siblings with the class’. Then the interaction stop working. I have set the trigger to affect the right class (I only got one to choose from at this moment)… and I just can’t figure out what I’m doing wrong. As soon as I take away ‘Affect class’, siblings etc etc, the interaction is working again.
Is it just me, or does anyone else have the same problem?
I could really use your help here.
Thanks!


Here is my public read only link: https://preview.webflow.com/preview/portfolio-2-template?utm_source=portfolio-2-template&preview=f6b6868bafd1874dcdc32ebf5a3df753


#2

Ooops… First solution answered the wrong question

Move “dropdown content” up a level in your hierarchy so it’s a sibling of the trigger, not a child.


#3

Here’s a screenshot…


#4

Thank you SO much for your help! So grateful!


#5

I’m glad it worked! I feel like a hero now… It’s my first reply to a question on the forum, haha. Don’t hesitate to tag me in future questions so I can take a look. @dont-pop


#6

@dont-pop I got one more question. When clicking on the trigger, and the content dropdown open, it’s supposed to push the rest of the content on the screen further down, and not ‘overlay’ Do you have any idea on how I can fix that? (I’ve duplicated drop down item 2 times)


#7

@dont-pop. I managed to figure it out… :smiley: For some reason I managed to set the content to absolute… and that was of course wrong.
Thank you again for being so kind helping me out! I’ll remember you till next time I need some help. I really appreciate it!