Streaming live at 10am (PST)

Interaction working on main tab, not on the others

#1

Hi,

So I wanted to have a list you can sort out, and I did it using tabs + collection filters (each tab has a different filter).

I’ve added interactions to my collection items, designed it on a tab (here, the “all” tab) and then duplicated my collection with the working interaction on each tab. Then I applied my filters.

Thing is, where I designed it, on the “All” tab, everything is working fine, but on the other tabs the interaction seems non-existent, even though in Designer I can see it.

Here you can see the interaction is linked on all my tabs. I checked ; it is the right interaction each time :

You can see it easily because the initial state of my elements aren’t the same from a tab to an other :

All tab, no element over my background :

When hovering, everything works as planned :

Now, an other tab is active. Elements are over my divs (they should only be when you hover) :


Here is my public share link

Here is a live published version.

Please ignore whatever has a “test” in the name, the folder and the collection. There is a big empty hero at the top of the page, please scroll down to see where I’m having issues in the “gallery” page.

Thanks !

#2

When you have this:

“selected element” means the selected elements and nothing elese, it’s not depending on its class, even if the element is named by its class. So you can reuse the IX as you want, it’s never gonna work.

You need, for each of the actions to select “Class” and “Only children with this class”

1 Like
#4

Thanks !

Sorry about that, I tried setting it as class first, but for some reason it didn’t work on the 2nd tab, so I gave up. When retrying, I noticed it was working on 3rd and 4rth tab.
I didn’t figure out why it wouldn’t work on that specific tab so I ended up deleting and redoing that tab and everything’s fine now.

Cheers

#5

Great it helped and don’t be sorry!