Streaming live at 10am (PST)

Interactions 2.0: moving by % doesn't work!

Hey!

I’m trying to use Interactions 2.0 to move elements on scroll. to my knowledge, this is the best way to do this in Webflow. I’d like the element to move, say, 50% at 25% scroll - this is exactly how Interactins 2.0 is supposed to work, so that’s awesome!

However, that’s not what happens at all. If I enter, say, move 50%, or even move 50vw, it moves only a really tiny amount. I need to enter a value like: 500%/500vw to get it to move, and it’s not responsive at all; it moves the same amount regardless of the screen-size (it seems to be behaving as if I’d entered 500px).


Here is my public share link: LINK

Hey benalexwilde - It looks like the position for the images on your scroll animation are set to 0px, while the movement is set to a percentage value. I would set the origin to 0% instead of 0px because the animations can act a little buggy if you aren’t using a consistent unit for each movement in the scroll. I also see that there is a legacy animation on some elements as well, which can cause elements to act strange in the animation. I would remove that legacy animation too, and then see if the elements start behaving properly. Let me know if that makes sense!

You’re absolutely right Paul, it was the origin position - I’ve now set them to % and they’re working correctly!

You’re a life-saver. I contacted Webflow support a week ago and still no reply; should’ve posted here in the first place!

1 Like