â–Ľ
Streaming live at 10am (PST)

Interactions all messed up after adding two elements


#1

I added a drop down nav and a back button animation and it totally messed up my previous parallax and slide in page scroll animations on tablet and below. Makes no sense whatsoever because I just turned those animations off for tablet and below. It works fine on the desktop view.

Here is the messed up view. Check it in tablet and below breakpoints: Messed up
Here is the working view. Check it in tablet and below breakpoints: Working one

Compare these two on my read only link at the bottom of this page:
31%20PM

Here are some images comparing how they’re messed up:


I don’t understand how this bug is created. If I copy and paste the drop down nav or the back button into the working page it will mess it up. Why would that be?

Thanks,
-Justin Marazita-


Here is my site Read-Only: LINK
(how to share your site Read-Only link)


#2

Any thoughts on this bug @Waldo @Brando @PixelGeek?

It’s really unfortunate to put so much time into a project and it work perfectly for all breakpoints and then add one element with the new interactions and it to breaks the previous hard work.

How do I fix this and how can we stop it from happening again?

Thanks,
-Justin-


#3

Both look and behave the same for me, after the tablet breakpoint


#4

Do you have it in preview mode? The photos are all rearranged in preview and the image of the wireframe completely disappears on the broken one.


#5

No following your link.

Why would the parallax IX work on anything but desktop if it’s set to only work on desktop?


#6

That’s why I think it’s a bug. If you go to the 2nd page on my read only file and go to the images and click preview they move for some reason…


#7

You have copy pasted elements with interaction, IX2, or duplicated pages, and the result is unlinked interactions and duplicated animtions

That’s how IX2 works, you can’t duplicate anything or it will break. Even cutting and pasting can break links.

Revert to a previous state where everything was workingand dont copy paste elements with IX2 or pages with IX2 or IX will break.


#8

That’s a major bug… So you don’t think I can fix what I have here? I just have to revert and do it all over again?

-Justin-


#9

I’d have to really go deep into what you made to properly answer and I don’t have that time. You can relink everything manually but that’s near to impossible if your elements are numerous and if they have combo classes, because they become hard to distinguish.

When I faced such a situation, I reverted. Now I don’t face the situation again because I don’t copy elements with IX2, or expect to copy. I actually only use IX1 for the time being.


#10

Thanks for the help. It’s terribly annoying isn’t it?

I just don’t understand how it would affect the stationary elements that don’t even have IX2 applied to them at tablet breakpoints and below… that’s the weirdest thing.

That’s hours of my time wasted… :skull:

-J-


#11

I understand yes. I’m not fully aware if and how and when this will change.


#12

@webflow Any news on this known issue? Not sure how it would mess with elements that don’t even have animation added to them.


#13

Hi @esoteric_designs

Thanks for posting about this issue and thank you @vincentfor helping out here. Losing interactions that took time to build is definitely frustrating and this is definitely something we are working on improving now.

I took a look at your preview link and it looks like you may have resolved the issue.

you can’t duplicate anything or it will break

To clarify, you can copy/paste or duplicate interactions, but when you do so you are creating brand new elements (they will have separate IDs). The action list of an interaction is associated with the specific elements you select by default, but you can choose to have the interaction affect a class name rather than the element.

So, when you want to copy/paste or duplicate an interaction, you can use the Replace element with class name first. Then when you duplicate the elements, the interaction will remain intact as it relies on the class name over the element itself.

I hope this helps and let me know if you have other questions


#14

@Brando. I still think there is a bug because it was affecting elements that weren’t even triggering animations. It was changing their positioning on the page or hiding them completely. Might be worth a look into.

I’ve reverted to an older version that isn’t broken. I haven’t added anymore interactions because I fear it will mess it up again.


#15

Thanks for letting me know @esoteric_designs

As you’ve reverted, I’m not able to look into your site directly to see if there are any issues. As elements were duplicated without Replace element with class name being used, it’s expected (at this point) for the action list to be incomplete.

However, our Interactions 2 team is consistently working on updates to prevent or resolve issues like the one you experienced. We have some updates coming down the pipe that should help avoid frustrations like this in the future.

I appreciate your feedback and help with this and let me know if you have other questions.


#16

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.