Streaming live at 10am (PST)

Interactions aren't loading smoothly


#1

Hello,

I've noticed that my interactions aren't loading smoothly on the first load of the homepage. Once you've fully played that animation once (in my case, hover over the element and let it play through once), it'll play smoothly from then on. Not sure what I'm doing wrong, any help is appreciated.

https://preview.webflow.com/preview/erindang?preview=6d200ee4c96685a6682be662c1f7c78a

On a side note, this is my first site with webflow. I'm really enjoying the experience and ease. Thank you for creating Webflow smiley
Another side note, feel free to give me feedback on my site! It's not done yet, so there's room for improvement.

Thank you


#2

Hey @MissFortunate!

Website looks great! Make sure to show that on our forum category here: http://forum.webflow.com/t/sticky-rules-for-show-tell-category/8

Not smooth interactions are caused by the fact that your website has a lot of images and those images are very heavy. Please see the following:

user-experience-interface

visual-design

At least these need to be compressed for the website to load quickly so your interactions are working smooth :)

I hope this helps, but if not then let us know and we'll be happy help you!

Cheers,
Bart


#3

Gotcha, I'll further compress some of my pictures. The main place where I see this problem prominently is my homepage. When you're first hovering over the UX/VIS links. I've noticed that the interactions (even just text) is just appearing instead of having the opacity and timing effects I've applied.


#4

Might have figured it out. Instead of using the Display: None setting, just set the opacity to 0%. This smooths out the interactions and will be smooth on the first load. So I guess this would be a bug report instead.


#5

Your site looks lovely @MissFortunate smiley don't forget to share it on Show & Tell forum category smile

Glad you're enjoying Webflow and part of this community. smile

Sincerely,

Waldo


#6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.