Streaming live at 10am (PST)

Interactions only work once


#1

Hi there,

Every time I add a show/hide interaction, I find it works great on the first hover or click but then if I click again it no longer works.

Here is my site: https://preview.webflow.com/preview/tootelo?preview=ff4b818cc7b03738aec70cef91261351

Please see the following pages : Social Responsibility (under About) where I started with an expand all button (I plan to remove it if I can get this to work, so they can just hover over each point to read more). Specifically the section 'environmental protection', the first point (smart travelling).

Also see Why work at tootelo? (life at tootelo) where the links show, I can expand them but if I click again they disappear. How do I get it to work continuously?

This will really help me because I will be able to apply your advice to many pages.

Thanks!


#2

You need to remove the transparency. You're setting the transparency to 0, and at the same time to 'display: none' - which is all you need to use anyway. This will solve your problem. Also, turn off 'loop' everywhere it's enabled.. Not necessary.


#3

You can make also make the code smaller by using the "Limit to sibling element " inside of affect another element.
This could help the load time in the page Why work at Tootelo
I'll make a little step guide
Step one
Change the class of all your hidden text to the same one (e.g hidden2)

Step two
Change the interaction of all the links to the desired interaction (e.g Show and hide)

Step three
Make the changes @JoeMillion talked about

Step four
Add the hidden text class to Affect another element (e.g Affect another element: hidden2) and click limit to sibling element


#4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.