Streaming live at 10am (PST)

Internet Explorer Site Load Problems

Hi Guys

Relatively new to Webflow. Totally not a coder. I have spent months building a new site for a client. But when the site is opened in Internet Explorer on other machines the layout is totally messed up and the fonts are not loading.

I have found by changing the width size of the elements to % it kind of cures the issue. But its a very large site and would take weeks to do this.

Does anyone have a work around the solve this? It works totally fine in all other browsers.

Thank You

Hi @DP43 and welcome to Webflow and this grand community. Sorry to hear about your issues. Lets see if we can tackle them for you right off the bat.

First off, congrats on building your new site.

Your subject line pretty much states the fact of your issue. IE is an unsupported browser these days. Unfortunately, Your site is built entirely around flex box and IE does NOT support flex box at all. This is unfortunate as I am sure you have spent weeks laying everything out.

Is there a particular reason why you need to test on IE? Do your clients ONLY use IE? If so, see if you can get them to transition to Firefox or Chrome moving forward?

I am sorry, wish I had better news for you. I would see how many of the users are actually using IE from your analytics before building it entirely around IE.

If you have any other questions, don’t hesitate to reach out,
Brandon

Actually IE 10/11 have partial support.
https://caniuse.com/#search=flex

2 Likes