Streaming live at 10am (PST)

Is it just me or is the Webflow support the biggest bug of all?

I’ve been really unsatisfied with the Webflow support lately. I know this channel is not maintained by the Webflow team, but apparently, neither is the official support function, and I need to relieve my anger somewhere. I’ve had serious issues with a few things in Webflow lately, like constant crashes and error messages when copy-pasting CMS items.

  • I’ve been reporting the issues through the error-message-popup - no reactions except automated e-mails.
  • I’ve tried to “contact support”, which is nothing more than a poorly programmed chat bot where you have to go through a 10-minute interview of questions every time, including having to go look for your credit card details every freaking time just to be able to contact support, then getting a message that “we will get back to you in 1-2 days”, which just never happens.
  • Webflow forum only works if some voluntary users have mercy with you and try to look up your issue - also, webflow users can’t correct bugs, obviously.

I remember how I really appreciated the support and the ease when using webflow for the first time, but I feel like they’ve lost it. I’m tired of being squeezed into answering a chatbot that is nowhere flexible, instead of just sending a freaking email. And I’m tired of feeling left alone with all the issues and problems that came up with Webflow lately. This is where it starts to go down with the hype.

You’re main issuers copy pasting CMS items, yes?

Are you getting lag errors? (Take forever to post?) is the error the same both in Designer and in Editir environments?

Is it easier to use when you’re in incognito mode?

Are you utilizing Webflow CMS API? (Extra useful if you have 1000+ cms items)

I have had fairly good experience overall with Webflow support, but that might be due to my team membership level, I don’t know how much support basic hosting and single users get.

But whatever your CMS issues are, I have also had my fair share of grievances with CMS but also found some good solutions.

I’ve noticed a drop too. Randomly in the middle of an ongoing case I was told to send in my credentials for verifications, as if the string of months of emails wasn’t proof I was who I said I was. Right now I’m in the middle of a case that started Feb 1 and I’m not getting any progress updates at all - apparently my site is too large??

Hello miek,

thanks for taking the time to answer me.

The issue is: I have a CMS collection in a div box, then I notice “oh, I actually want it somewhere else outside the div box” and try to drag-and-drop it in the navigation panel, but it’s stuck and won’t move. Then I try to copy and paste it to get it outside the div box, and then it crashes (it’s so reliable I actually already know “okay now it’s going to crash”.) The only way to get it ouside the div box is to completely recreate the collection list and it’s styling at a different place. It doesn’t happen with all the collection lists, though, but I couldn’t figure out yet, why and when exactly.

But this is not the only time webflow crashes. I’ve had crashes when trying to open symbols on some pages, too. The exact same symbols can be opened without a problem on other pages.

Actually, I’ve had so many crash-and-error-moments lately, I don’t even remember them all.

I did not try if I have the same issues in Editor environment. I’m actually never using Editor. I will look into it.

When trying to use Webflow in incognito mode, it keeps telling me it won’t work when using a browser that does not allow third-party-cookies.

I don’t know what Webflow CMS API is, but we do not have 1000+ cms items. We have around 50, I think.

We’re not on basic hosting but CMS hosting. I’m posting this from a different account.

Hey, so I took a look at Editor, but it’s not suitable to test since Editor is not for Layout changes (as I understand).

I also tried a different laptop, different environment, but still, same crashes.

I have a page section where I want to filter a CMS list with tabs and I will have to recreate the list for every tab manually instead of copy-pasting it. It’s unbelievable and Webflow won’t react to any messages.

@loewenkunst

I might suggest setting CMS ti Limit 1 Start on 1. Before copying it. I’m curious if that still crashes it for you.

I’ve encountered similar crash events before like you described with CMS collections and symbols.

Do you have a share link and/or loom.com video. It would to easier point out.

Here are some things in webflow projects I found to make it lag out:

  • Lots of redundant assets in assets panel
  • Lots of redundant CSS in styles (div block, div block 2…divblock 99 etc)
  • Lots of redundant IX2 triggers and animations (Animate Block… Animate Block 2)
  • lots of redundant font loads (using multiple font families on the same page)
  • lots of conflicting styles in custom code
  • lots of conclicting combo classes
  • lots of cms-rewrites

This may not be a popular opinion, but whenever Webflow designer starts crapping out on me, I usually take that as a sign a new iteration is in order. Every single time I reiterate, the whole experience becomes more seamless and get much better performance scores on Lighthouse.

Hey everyone,

after a while the Webflow support did get back to me and it turns out it was an actual bug. They showed me a workaround for now and promised to get rid of the bug asap.