Streaming live at 10am (PST)

Issue where link blocks and links that are not set refresh the page

I have an odd bug where link blocks and links that do not have a destination page yet. Will refresh the page. Links that are linked to a specific page (or in-page link) do work correctly.

Anybody also experiencing this issue or know a solution?

Thanks in advance

Read only link: https://preview.webflow.com/preview/equiem-2018?utm_source=equiem-2018&preview=4975a9c5461aca6a7b95bf219795e17f


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

It looks like starting recently the links are all created with # by default and if there is nothing in the address they will link to the page they are on. Looks like if a link had an interaction on it but no actual link address the page will not be refreshed (at least this is the case on my current project where I noticed this behaviour)

Hi @dram . Yeah just found this out as well. Looks like new links have #. Without it they link to them selves. Thanks for your reply mate!

Yep, some internal engine changes made a lot of panic among users. Hopefully WF will do something about this and fast.

Yeah lets hope so… more websites of mine are having problems at the moment :frowning:

Hi @martijnrunia and @dram

Yes, this we did some investigating on our end and it looks like this is an issue caused by a recent update that causes blank links to refresh the current page.

Our team was able to push a fix and any links with a blank href will no longer cause the current page to refresh.

​Can you please confirm this on your end by first republishing your affected project(s) then test the links?

​Thanks in advance :bowing_man:

1 Like

Hi @mistercreate, thanks a lot! Just republished all my sites and and it works. Now I can leave my house for a short weekend trip with a peace of mind ;)!

Thanks all!

1 Like

Oh, awesome! That’s great to hear!

Yes, peace of mind :peace_symbol:

Feel free to contact us if you have any additional questions.

I’m standing by to help further!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.