Streaming live at 10am (PST)

Issue with display visibility

#1

Hi! I’m having a small issue with the display visibility of a section. I’ve checked this article but still can’t make it work. https://university.webflow.com/article/display-visibility

The Read-only link of the site is https://preview.webflow.com/preview/bitz-redesign?utm_source=bitz-redesign&preview=93ebbab3b4ee035adbcf631398d801ca and live site https://bitz-redesign.webflow.io/customers

In the For Customers page and then in the How it Works section, I’ve created two sections, one for desktop with full mockups and the other with cut for tablet and mobile. I’m trying to use display visibility in order to show the full mockup section just in desktop and the cut ones in the rest.

I had no problem hiding the full mockup section for mobile and keeping it in desktop. However, I’m trying to hide the cut version in desktop and I can’t do it. I’ve tried starting from mobile and go to higher breakpoints but when I reach desktop and I hide it there, it also hides the section for tablet and mobile, making it impossible to just hide it in desktop.

Any idea where I’m fucking it up? Looking forward to hearing! Have a nice day everyone!


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

#2

Like this?

#3

Exactly Vincent! That’s what I’m doing but in your case I don’t know why after hiding it in the desktop view you can still see it on other devices but in my case it disappears. I’m not sure how you uploaded a video recording but I can share mine through so that you can see what I’m doing. https://drive.google.com/open?id=1IvtjJBmknhSS8y5x-KvpwKnvJQsS9N9C

#4

Haha, that’s expected.

Because I went to devices to actively click on visibility before hiding it for desktop.

ANYWAY: 2 solutions for the workflow

#1 When you display none an element, it disappears but it stays selected. So just pass on the devices view and make it visible again
#2 You can go in the navigator panel, select the element, go to devices and make it visible.

I’m using Monosnap app on Mac. On Windows there’s probably CloudApp that’s making a similar job of sharing captures and video captures easily.

#5

Now it’s working, I was not actively selecting the view on each device. Thanks Vincent! Will also check CloudApp, have a nice one!

1 Like