Streaming live at 10am (PST)

Issue with hover drop down menu not showing correct menu


#1

Hi

Just a quirky issue with a dropdown on my main navbar.
I have set up an interaction to display the drop down menu on hover for the nav link, titled 'Get to know us'.
Atm its showing a grey coloured drop down menu, which is incorrect, it should be blue with white text.
When u click on any of the three navlinks it will show this blue drop down menu.

Any idea why its showing a grey coloured drop down menu instead?

https://preview.webflow.com/preview/calaisfs?preview=1377508e9e40d228a650b8f1d78750d6

Thanks


#2

Because you use a Dropdown widget, it works like when you click on it it unveils the dopdown list, and when it's unveiled, it has a Open dynamic class to it:

When you want to style your list, you select the menu, you click "Open" in settings, which gives the list the Open class. That's what you're styling.

But by "cheating" and openingyour menu on /hover, you display the list but you don't get the Open class, hence your blue background being never triggered.

So instead of opening your list to style it, juste select it from the navigator and give it the bg color.


#3

EDIT: Managed to get everything to work out just the way i wanted! All guuud smile

EDIT2: PLEASEEEEEEEEEEEE provide Tablet Landscape mode! It makes it sooo much easier to design rather than create extra code just so everything fits into this particular mode. Prettty Pleaseeee!!


#4

Haven't seen your previous request, just saw this update... then good job (:


#5