▼
Streaming live at 10am (PST)

Issue with mobile version hero buttons and load times


#1

Hi there,

Please see http://qp-v2-353a27.webflow.io/ for details on mobile version, landscape or portrait.

The buttons appear perfect in design mode, but on mobile, the buttons overlap and when you scroll down a little, the buttons look just fine...

Never had this issue before with hero buttons, so not sure why I'm having such an issue this time.

Any help will be appreciated :slight_smile:


#2

Hey @Daniel_Kempe,

That is one killer website design :stuck_out_tongue:

Can you share your read-only link please? https://help.webflow.com/article/how-do-i-share-my-sites-read-only-link

Best,
Naweed


#3

Thank you! I think this is the one :slight_smile:

https://preview.webflow.com/preview/qp-v2-353a27?preview=8bafd9c4961ce919799fb6e76996b4d5


#4

Also, on mobile, it won't even load now at all, it gives an error - "A problem repeatedly occured on "http://qp-v2-353a27.webflow.io/".


#5

Hey @Daniel_Kempe,

Is this resolved or ongoing? I still can't access the read-only link.

Best,
Naweed


#6

No, it's still not working on mobile. It doesn't even load sometimes and just gives an error. The read-only link is above and below:

https://preview.webflow.com/preview/qp-v2-353a27?preview=8bafd9c4961ce919799fb6e76996b4d5


#7

Any ideas? I'm hoping to launch the new app soon, so need this website up and working asap! Thanks.


#8

Hi @Daniel_Kempe

Thanks for getting in touch. Can you please make sure that the Share link is on (https://cl.ly/0H1H2h1F3m0K) and that the website is published.

Both links you provided are returning a 404 error.


#9

Ok, I'm sure I did that. New link below:

https://preview.webflow.com/preview/qpromote?preview=b7dfb0d60d5eac03c87c5103f825b7a8

Thanks.


#10

Hi @Daniel_Kempe

Looks like there's a float: left set up on the hero button which is making the buttons overlap.

Here's an animation showing how it can be fixed:

Setting float: none should fix the problem.

​Hope this is helpful.


#11

Ok, I've done that, but the site will still not load on mobile, chrome or safari.


#12

Hi @Daniel_Kempe

It's loading fine for me:

What device(s) are you using?
Are you still getting the error message you mentioned above?


#13

Yes, using iPhone 7 plus on chrome and safari. It tries to load, but gives that error above on safari, and Awww snap on Chrome.

Also, the screenshot above you uploading, the button is a different size...


#14

Ok, now it's loading fine, weird! Will try and sort the button now. Thanks for all your help.


#15

Glad to hear it's working.

Good luck with the button and your project!


#16

Thanks, not sure why the button is a different size.. looks fine in design view.


#17

Please see attached screenshots. The button is wrong when first loaded, but if you scroll a little, the buttons are perfect again. Why is this happening?


#18

Hey @Daniel_Kempe,

I couldn't reproduce this in my browser. Although, the 'Learn More' button has a width of 220px compared to the green button with 100% width.

Keep us updated.

Best,
Naweed


#19

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.