Streaming live at 10am (PST)

Issues with image slider on ipad


#1

Hi everyone.

this website has issues with the way its image slider looks on ipad.
http://illusive-networks.webflow.com/

for desktop it has a video and for tablet and phones i use an image slider instead.
the problem is that on an ipad i experience issues with the way image slider behaves.
the first thing i noticed is that in portrait view the transitions are ok but for some reason the first image (which i duplicated twice for timming purposes) has a grey bar at the bottom which dont appear on the next 3 images (the last two are also the same) this happens only on ipad in both portrait and landscape views.
now in landscape view this problem occurs along with another issue which is that the transitions between images dont work well and they cause the screen to flicker as if the site is constantly refreshing - as if the ipad cant handle it (in portrait view this problem does not happen)
for landscape view i used a media query of 1024px which hides the video and shows an image slider i made visible only for desktop/ipad(landscape) behind the video. that way on ipad i see the image slider instead of nothing.

also when i tried to put in the embed the fallback image for the video it appeared at a tiny scale inside a narrow black strip. is there anything i can do with the code to make the fallback image for the video to look exactly like the video? (considering that the video is 2540px width and its getting cropped as window size is getting reduced.

here is a work link:
https://preview.webflow.com/preview/illusive-networks?preview=ff3b8bc0233380a9ab8be5eaab92e7c4


#2

does anyone has a clue? this is a very wierd thing happening only on ipads


#3