Streaming live at 10am (PST)

Issues with layout on IE!

I’m experiencing the following issues on I.E. Any ideas on ways I could fix? Read-only site:

  1. Homepage: in the Services section, text breaking out of boxes:

  2. Services and About pages: hero image not appearing correctly:
    2019-04-23-1

  3. About page: there’s almost an entire page of white space after the bios:
    2019-04-23-2

Any thoughts or suggestions greatly appreciated!

Matt

Take a quick look at topics in the forum for “IE 11”. This is an often discussed topic. Not something that you can get a quick answer on. Google is showing 825 unique pages in these forums.

https://forum.webflow.com/search?q=IE%2011%20browser

TL;DR
IE is an old browser that is not receiving any more feature enhancements. since it officially EOL. If you need support for it, then don’t user features it does not support.

Hey @MDR77

For the first issue, add a width of 100% to the paragraph in your Feature card, I tested on IE11 and this fixes that problem. :tada:
CloudApp

With IE11, you need to be explicit with a lot more of your items, whereas newer browsers will understand that the paragraph is a child and shouldn’t expand beyond that element, older browsers fail to do this, so kindly add all you text on one line. :man_shrugging:

I’ll take a look at the other issues if get chance, but try that with anything else that you have a problem with, add definitive values where they may be missing.

IE is an old browser that is not receiving any more feature enhancements. since it officially EOL. If you need support for it, then don’t user features it does not support.

:point_up: +1. You’ll have more and more issues with IE11. I no longer offer support to any of my clients who may decide to use it.

1 Like
  1. For the Services and About page, set the explicit position values for the position: absolute settings…
    either by clicking the full icon, or setting the percentage values.

CloudApp

That works! Thanks very much! Just need to figure out issue #3

Yep, I had a quick look but can’t see what’s causing it. Just make sure heights are set, and if you use absolute positioning anywhere that the values are set too.

I’m not sure if typing Auto in the height field does anything, so it’s worth a try on that. We don’t offer official support on design or old browser issues, but if I can figure it out then I’ll let you know.

It’ll be something simple like the others though for sure :slight_smile:

Actually writing “Auto” for height (rather than the pre-fill grey “Auto”) fixed it!

Thanks for all your help! These forums are really helpful and so active.

Great news! Thanks for letting me know. :raised_hands: :tada:

Yeah the forums are so helpful and a great place to be a part of and learn! If you ever get the chance to pay it forward and help out someone else then it’s always appreciated :smiley:

Welcome to the community :webflow_heart:

1 Like