Streaming live at 10am (PST)

"Jerkiness" when scrolling down the page (not interactions)


#1

I had initially thought this was due to interactions, but when I remove the interactions I still see a “jerking” when scrolling from one section to the next.

https://preview.webflow.com/preview/marks-fantabulous-project-8bb5d7?preview=f1172e7f74fc49aec611802a07e294c7

Am I crazy? How does one fix this? It’s exacerbated when I try to add interactions.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)


#2

Can you post the actual published page? This helps isolate things from the designer platform.


#3

Sorry…. www.scalableb2b.com http://www.scalableb2b.com/ is the site


#4

Seems fine to me, but your “Learn More” buttons are acting weird… they show as squares, then when I hover over them, they turn into rectangles (how they should be).


#5

Are you using Safari?


#6

When I opened your site, yes… I’ll check Chrome and the latest Firefox if ya want me to.


#7

Yeh, I think I’ve isolated the issue to chrome. Let me know what you see.


#8

In Chrome, on initial scrolling, it was a lil jerky… but going back up and down again was fine… almost like the caching had to take place before it was fine.

Firefox was fine all around.


#9

Tried on iphone8 plus. No jerking. One thing - the interactions seem to be coming in a slower speeds the further I scroll down the page. No sure if this is intentional


#10

Thanks for that, I’ll check it out. I am still figuring out the whole IX2 thing.


#11

Thanks for looking at it. Any suggestions on how to deal with the caching?

I am sure it’s probably not all that noticeable to the average visitor, but for me it’s a glaring issue that drives me NUTS.


#12

All I know is that since Webflow hosting is managed hosting, we have no direct way to tell the server how to behave.


#13

So, I think I fixed it!

I went back and made the images smaller and that seems to have done the trick


#14

I ran into the same issue, and I figure it’s something to do with Chrome. It happened not on my laptop, but my workstation pc which has a dedicated gpu feeding two 22" monitors. There is plenty of gpu ram for website rendering, yet something within my website was causing scrolling to become jerky. Almost like Chrome was struggling with its draw refresh.

Didn’t happen on mobile version of site, tablet, or laptop, just on my workstation.

Do you know if your gpu is dedicated or integrated? I might be way off the mark with my observations, but it seems plausible.


#15

Guys… I don’t mean to insert… but uhhh… here’s the problem:

Move your mouse to “Scroll 1 at a time”.

Just teasing… give that a try… it worked for me. It’s a little slower, but smoother. *And it will smooth out grabbing scroll bar much better.


#16

Where do I find that


#17

In Windows 10 - Start - Click Cog/Settings - In search bar, type mouse, click mouse settings. “Roll the mouse wheel to scroll”

Cog is on left side bar bottom

:slight_smile:


#18

It is actually when dragging the sidebar up and down. It is only on some projects that use a higher res background image. It’s the way chrome renders it on larger displays, because the same page run on a say, a laptop, does not have the same problem.

I know what you mean with the scroll multiple lines at a time option, but that is very different from what I was explaining :). Thanks though.


#19

Okay, no problem.

  1. Now you can add a snippet of custom code to slow down the scroll wheel and the entire page, which will for sure slow everything down. This may be the best option if it bugs you.

  2. Another option: Add a loader, which allow all the assets to load before javascript and other action happen. There may be a slight doubling/conflict of code on the page. Try a loader and see if it’s slows down the rendering a bit.


#20

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.