Streaming live at 10am (PST)

JQuery version 1.11.1 or 2.1.4? What's the difference?


#1

I see that every Webflow project contains JQuery version 1.11.1

But what if I want to use a script that require version 2.1.4?

Will this not cause a conflict?


#2

Hi @rajsidhu, thanks for the question ! The short answer is that it depends on the jquery functions that you are using, there may be a conflict arise, depending on the plugin you are using.

jQuery has a built in function called noConflict(), which may allow you to work around the dependencies.

See this documentation from jQuery: https://api.jquery.com/jquery.noconflict/

Webflow does not provide technical support different versions of jQuery different than is used in Webflow sites or custom code of your own, so my suggestion is that if you are needing to do a custom code integration, to test out the code, play around with it, and see how the custom code works for your solution

​I hope this helps !


#3

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.